BPI-M2 zero new image: RetroPie for Banana Pi M2 Zero v.1.2.1 beta

BPI-M2 zero new image: RetroPie for Banana Pi M2 Zero v.1.2.1 beta


RetroPie for Banana Pi M2+ BPI-M2 Plus v.1.1.0 beta

Two questions how do you connect to WiFi, as every way I’ve tried has failed but others here and the WiFi is fine so I know its not the board, even tried it from within the terminal to no avail, 2nd is how do you load ROMs as with no WiFi cuts my options to USB and tried a few ways there but it doesn’t even pick up the drive itself any help would be nice, also read the documents on the board bpi m2 zero says it can run a bunch of operating systems but I only see betas why is it advertised it can run raspberry pi imgs if it can’t?

So managed to get ROMs loaded on it was tough given no WiFi or USB access, is there a way to get them working, as I can sign into WiFi just won’t connect, also found out sound doesn’t work, nor does the n64 emu how to get it running or select what cores are being used

I got WiFi running now steps are f4 to cmd line enter sudo wpa_cli then press enter, then type scan press enter, then type scan_results press enter, then type add_network press enter it should give you a number then type set_network (add the number it gave you after network so an example set_network 0) said " your network name" ( with quotation) should look like this set_network 0 said “bananas” press enter, then type set_network 0 psk “your passkey” should be the same as the one before just change the psk and passkey, hit enter then type select_network 0 (or whatever number value it gave you) wait for it to configure then type quit hit enter then type sudo dhclient hit enter and you should be all good to go, I used the WiFi under retropie setup option and under config/tools option as long as you see your network name and an IP your golden. Hope this helps still trying to trouble shoot the no sound

This didn’t work for me. It said connected but still no IP. Hopefully a newer image will come out and have this fixed.

I got it working once then it stopped after, but it can work via cmd line I just don’t know if there was maybe a step I missed or something

Gave up on it for a little bit as have been working trying to get the sound working cause aside from the sound/ WiFi it works pretty well a lot better then a pi zero and n64 games play pretty well on it

To get Wifi working I manually set it up.

in /etc/network/interfaces goes:
    source /etc/network/interfaces.d/*
    allow-hotplug wlan0
    auto wlan0
    iface wlan0 inet dhcp
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

In /etc/wpa_supplicant conf goes:
    	ssid="network here"
    	psk="key here"