BPi M2 Zero - first use question

Hi All

My first post is a question about the M2 Zero.

Booting up for the first time, how do I proceed after entering my username and password?

I’m using image 4.2018-4-30 update BPI-M2 Zero & P2Zero Ubuntu Desktop 16.04 on a Kingston 32gb class 10 SD card.

After startup I get to the point where I enter the username and password.

After entering username as pi and password as bananapi the following appears:

Last login: Thu Jan 3 17:06:38 CST 2019 on ttySO

[email protected]:~#

And that’s where it stops. Can anyone tell me how to proceed from here please?

Many thanks in advance

zub

You’d better try the latest Linux image http://wiki.banana-pi.org/Banana_Pi_BPI-M2_ZERO#Linux

or Armbian image here https://www.armbian.com/bananapi-m2-zero/

Thanks - sorry to have not replied earlier but I haven’t been able to log onto the forum. That sort of helped - the 2020-04-28 release got me as far as the Ubuntu desktop but at that point I have no power going to keyboard or mouse and the red led on the BPi M2 Zero keeps flashing twice. I’ve changed the USB cable but no luck. I tried the latest Raspbian image (2020-04-10-raspbian-jessie-ap6212-bpi-m2z-sd-emmc.img) which booted really quickly to the desktop but I still had no keyboard and mouse working and the red led on the Pi was flashing twice repeatedly as before. I’ve checked other posts on the forum and other users have reported the same thing but no-one could supply a definitive answer. 2 red flashes must mean something. The same thing happening with 2 different images indicates that it’s not an OS problem and the keyboard and mouse not powering on indicates that there’s a usb / power problem. Any ideas anyone?

I have two Micro USB to USB OTG Adapter Cable, both work fine with 2.4G usb keyboard/mouse dongle. check your otg adapter, or may be compatibility issues.

I’ve tried 3 cables and still nothing. I checked that all the cables worked for power and data and they’re fine. The power gets from the board to the hub (the led lights on the hub) but not further. The hub works fine with other pc’s, laptops and Raspberry Pi. I tried a different hub with the Banana Pi but no luck. I’ve got a powered usb hub on order - I’ll see if that helps.

I’m writing the image to the SD card with Belena Etcher - should I be using something else?

Both, Ubuntu and Raspbian, are very low quality … Use Armbian, where your chances for usage started. Its not without bugs, but a lot less. And there is active development going on. And you need to get this https://linux-sunxi.org/UART to debug problems you have.

Thanks - I’ve just tried Armbian but it’s exactly the same (except this time I never reached the desktop as I was unable to enter the password). During the startup I saw 3 entries for USB and all were OK. I’ve tried not using a hub and connecting directly to the keyboard or mouse but that doesn’t work, neither does using a wireless keyboard. I’ve never used a UART before but I’ll give it a try.

If you plan to stick to development boards (one of the cheapest consumer things to run Linux), this a must have tools.

Can’t say why USB doesn’t work. I would try Armbian image with different kernel version. If you went for 5.14.y now, try 5.10.y and vice versa. That is the only difference on the hardware side.

Try booting with attached keyboard, attach later, …