BPI-M2 New Image (Raspbian V4.0) Release

BPI-M2_Raspbian_V4.0 HDMI MD5: D1F6E70764C96EBA209707E35F78F398 http://pan.baidu.com/s/1sj7iCC9 https://drive.google.com/open?id=0BzoTh3Vdt47fQzd0V1lFYUQtS0k

LCD MD5:5191FE3E7364A81BEE911C555EFD7BCC http://pan.baidu.com/s/1bnuJUVH https://drive.google.com/open?id=0BzoTh3Vdt47fQUtRU1k3NVBYbFk

Release Note:

  1. Gigabit Ethernet issue fixed.
  2. BPI-LCD’7 display supported
  3. Touch Panel feature supported
  4. GPIO-40Pins defined
  5. Kernel 3.3 optimized 6.WIFI support. 7.build from BPI github. 8.username/password: bananapi/bananapi

Hello, downloading image right now, but what about USB - all ports are working?

USB 4 port all working fine . but note : if you use OGT power BPI-M2, only two USB working , you need use DC to power ,

I see USB ports are working, but why only 720p GUI resolution without options?


Thank you for your work! I downloaded the HDMI version via Google Drive but i am not able to log in. I tried: pi / bananapi pi / raspberry

and a few other combinations. Am I doing something wrong? I tried the newest ubuntu released and with that i can log in, but i need raspbian.

Can you provide in near future a minimal server release with command line and only neccessary tools (ssh, java etc.?)

Thank you

sorry username/password: bananapi/bananapi

Thank you!

How can i disable the gui? I want to run from command line and have minimal ram consumption. I tried raspi-config, but all i get is black screen after restart. Can you please provide a simple server image with minimal installed programms?

How to access GPIO pins. Is there example code someplace in the image to show how to access GPIO?

1 Like

Please, Don’t work to LeMaker LCD?

we not test on lemaker LCD, you need give us more message about this .

1 Like

HI abhinavmathur: you can reference it

Step 1: Please re-compiler M2-BSP. Change the following files, boot.fex , env.fex , and 3.3.0-BPI-M2-Kernel. (http://forum.banana-pi.org/t/m2-bpi-m2-bsp-updates/353/1])

Step 2: Go to github, Download WiringPi for M2.

HI BananaPiBeginner: Maybe, you can see this for your reference. (Building a Minimal System with BPI-M2)

Thanks Justin. The GPIO on the M2 work now :smile:


I have installed Raspbian Image on BPI-M2.

Everything works fine, except when connecting my Prolific USB Serial device then no serial device USB0 is created.

This working fine on my Raspberry A+.


lsusb -t 1-1.3:1.0: No such file or directory /: Bus 05.Port 1: Dev 1, Class=root_hub, Driver=sw_hcd_host0/1p, 12M /: Bus 04.Port 1: Dev 1, Class=root_hub, Driver=sw-ohci/1p, 12M /: Bus 03.Port 1: Dev 1, Class=root_hub, Driver=sw-ehci/1p, 480M /: Bus 02.Port 1: Dev 1, Class=root_hub, Driver=sw-ohci/1p, 12M /: Bus 01.Port 1: Dev 1, Class=root_hub, Driver=sw-ehci/1p, 480M |__ Port 1: Dev 2, If 0, Class=hub, Driver=hub/4p, 480M |__ Port 3: Dev 6, If 0, Class=vend., Driver=, 12M

Raspberry A+ Output /: Bus 01.Port 1: Dev 1, Class=root_hub, Driver=dwc_otg/1p, 480M |__ Port 1: Dev 2, If 0, Class=hub, Driver=hub/5p, 480M |__ Port 1: Dev 3, If 0, Class=vend., Driver=smsc95xx, 480M |__ Port 3: Dev 7, If 0, Class=vend., Driver=pl2303, 12M

The pl2303 driver is loaded on the Raspberry but not on the M2. The Raspberry creates the ttyUSB0 device.

Your assistance with this issue is appreciated.

Thanks, Brent

Hey justin how about the spi, uart, and i2c? On the bpi-m1+ there is a script.bin file that we could decompile to script.fex and then edit the hardware but there is none on the bpi-m2. Is there any way to edit the 40pin to use as a uart/spi? Tried the wiring pi but there is no hope

Good day how I can get access to download


I’m searching for the BPI-m2_rasbian image too… Can plz someone make it possible to download this image? Support from banana does’t answer.

greeting, Bill