Bpi-copy: INFO: /dev/sdc NOT THE removable device! EXIT!

Hello, trying to get a M2 running.

The SD card is attached to my desktop on ubuntu, system calls it “sdc”. So, when calling bpi-copy, I get:

$ sudo bpi-copy 2022-09-27-Armbian_22.11.0-trunk_jammy_edge_lubuntu_5.19.6-qt5-swap-bpi-p2z-10804MB.img /dev/sdc
bpi-copy(v1.3.4(github)), bananapi image & disk tools

Usage: bpi-copy [OPTIONS]...
       bpi-copy [ --help | -v | --version ]
       bpi-copy IMGFILE
       bpi-copy IMGDIR
       bpi-copy IMGFILE DEVICE
       bpi-copy DEVICE IMGFILE

Warning: Try to write 2022-09-27-Armbian_22.11.0-trunk_jammy_edge_lubuntu_5.19.6-qt5-swap-bpi-p2z-10804MB.img to BOOTDISK /dev/sdc
Mo 2. Jan 09:10:30 CET 2023
*** start COPY (blue led on ) .....
INFO: /dev/sdc NOT THE removable device!! EXIT!!

sdc definitely is not the bootdisk of my desktop. My wrong? What can I do?

Does bpi-copy in line 238ff look for a mmcblk device - which will not always be present in a desktop system?

Cheers, Wolf

In my case bpi-copy only work on the SD to write the mmc. On my desktop I use balena or dd command to write the SD.

Thanks for clarification. As I did not yet have any success with dd oder USBImager, I tried this idea - but obviously it’s a dead end.

I tried these images for a BPi-M2 Zero - H3:


Both regularly lead to a red LED flashing twice any second or so, and no picture on screen. Should these images be good?

Cheers, Wolf

The problem with the images is that some of the drive do not work right. Despite being in their drive.

I use this: 2020-04-28-raspbian-stretch-bpi-m2z-sd-emmc.img.zip

Thank you. I’ll keep trying.