Boot problem BPI M3 V1.2 only booting with 2 powersuppy

Hey guys,

I ´ve got an BPI-M3 V1.2 and want to get him started with following Powersupply: DC-IN 5V 2,4A. After many tests with differnet images and SD-cards, I saw anybody who has solved his boot problem with 2 powersupplys at the same time. So i went on and get my BPI started with DC-IN 5V 2,4A & MicroUSB 5V 1A and the Board works and is booting correctly. After the boot I´m able to remove the MicroUSB and the Pi works only with the DC-IN.

Does anybody now how to fix the problem ? ( I only want one powersupply, I ´ve tested it also with DC-IN 5V 4A, but the board doesnt boot without MicroUSB)

Thx grikofant

if you use 5V/4A , BPI-M2 will not boot , we design power protection on board , so ,just need use 5V/2A,BPI-M3 will working fine.

You could try Ubuntu_15_04_Loboris_BPi-M3.img.7z image from with just your 4A PSU connected to DC jack (no Micro USB connected)

We allready tried it with 5V/2,1A yesterday, but it still doesnt work. Do you think the problem is because of the 2,1A instead of the 2A ???

THX for this image ! Its the first one which is bootable without MicroUSB only PSU from the USB-HUB (max 2,4A) I´m allready testing it !

The above answer by @sinovoip is unbelievably wrong. A device draws the current it needs and it’s absolutely irrelevant how the amperage ratings look like as long as the PSU can provide as much as (or a little more than) the board needs. But unfortunately this pretty much describes the whole support situation/quality here.

According to Armbian forum they introduced your problem with this commit: