BananaPi BPI-M3 New Image (New Emmc) Ubuntu16.04 & Debian9 Release 2018-07-18

BPI-M3 New Image (New Emmc) Ubuntu16.04 V1.1 & Debian9 Demo Version Release 2018-07-18


1.About this release

  • This release is for banana pi M3 board which is based on Allwinner A83T, We release three Images, Ubuntu 16.04 Desktop & Server is based on kernel 3.4, Debian Jessie 9 is also based on kernel 3.4.

2.M3 Ubuntu 16.04 Mate Desktop

  1. Features Map
  1. Image Links:

3.M3 Ubuntu Server

  1. Features Map
  1. Image Links:

4.M3 Debian Jessie 9

  1. Features Map
  1. Image Links:


Pls share images to google drive asop because this is a problem to get baidu account not from Mainland China

Hello, I posted the google links.

thx. i had tried 4.M3 Debian Jessie 9 with 7 LCD (bpi-bootsel /usr/lib/u-boot/bananapi/bpi-m3/BPI_M3_LCD7.img.gz) and touch screen not working. i ll try modprobe ft5x_ts and it does not helps me to solve problem. may be you know why?

Hello,my LCD screen is HC070TG, it could work when I tested it,what is yours?

If Debian could not work, could you please try Ubuntu?

BPI LCD S070 V3 2015 08 S070SWV20HG-DC16

I had triyed all 3 images and at Ubuntu Big and Debian Jesse touch is not working. at Ubuntu Lite after i had install Xserver touchscreen is working. i will try to assambly what i need at Ubuntu Server(Ubuntu lite) version. Thank you for you Great work.

where i can buy you LCD module?

Is it possible to compile one image for the BPI-M1?

How do you create these images? Can you create a Debian Server Image please?

Thank you very much for your service providing these images! If I only could create them myself

Hello, M1 Image I will release in the next week. because I don’t have M1 board now.

I will write the method in the wiki, and you will see.

Dear all, good work :sunny: The debian image works now very well for me. ubuntu doesn’t upgade proper - so debian is now my candidate. Some things I had to fix - might be also interesting for others:

  • pulseaudio is always unhappy with the old kernel: “shared memfd open() failed: Function not implemented” => add “enable-memfd=no” to /etc/pulse/client.conf

  • Linking error when running own compiled binaries: “error while loading shared libraries: /usr/lib/arm-linux-gnueabihf/ invalid ELF header” => cd /lib/arm-linux-gnueabihf/libc => sudo ln -s => sudo ldconfig

  • set performance mode, specify the governor to use at boot. Edit /etc/default/cpufrequtils (you might need to create it if it doesn’t exist). Specify the governor with the GOVERNOR variable: valid values: userspace conservative powersave ondemand performance get them from cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors:=> GOVERNOR=performance

Cheers, Uwe

1 Like

Hello i have a question how ai can change display mode in image burning on mmc ?

Hello,Please see Here:


Hi, How can I stream usb camera video? I’m using Logitech c930e (which with guvcview cooperate fine, device is listed in lsusb etc…). I was trying to use mjpg-streamer but it failied unfortunatelly. Currently I have installed M3 Ubuntu 16.04 Mate Desktop (which seeams to work stable with my new emmc memory). I need video streaming for my 3d printer (software for Octoprint I have installed and it runs ok, just camera problem only left). Please advice any solution for live streaming.

hello, please try this shell : ./usr/local/bin/

Hi I’m facing a problem with touch module (HC070TG38035). I have tried this module with BPI M1 and M64 boards, touch is detected but not corrected calibrated. I have used ubuntu desktop 16.04 image in both cases, getting the same result. Could you help me with this issue?

I have opened a new post: BPI M1 and BPI LCD 7" (HC070TG38035)

Did you have other board? Both M1 and M64 have this problem right?

Hi Jack.

Yes both have this problem. I don’t have another board.

Thank you.


LCD module finally works with BPI M64 board!!! We updated drivers from and used gt9xxnew_ts.

Thanks for your help.