Banana won't power up with hdmi cable connected

HI all, My new banana banana board (bpi-m4) won’t power up with hdmi cable connected (pwr and act LED off). Disconnecting cable cause banana both pwr and act LED’s to turn on steady.

Reconnecting HDMI cable with LED on did not cause to turn they off.

Is my board broken or am I missing something?

Thanks a Lot

Not much will happen without a compatible image burned to the SD, first place to start to gen yourself up on the board and capabilities is :

that site also has links to what appear to be homebrew images, aka images created by users like yourself, some are useful. But to begin with I would strongly suggest you start with the official images release by the maker:

first boot with fresh image may take a while if it’s still not displaying anything try following key sequences, I would go through all the f keys. Issue: if HDMI doesn’t display, please try “ctrl + alt + F1” to change terminal then “ctrl + alt + F7” change to desktop display.

if that doesn’t work try, switching the switch near the SD after pulling out the power cable then try again, this switches between linux and android partitioning I think.

Thanks a lot for your reply.

Meanwhile I tried to connect USB2Serial interface, I had a u-boot shell, so i guess that board is working (and image on sd-card is bad):

*C1:80000000 C2 ?_? C3h hwsetting size: 00000950 C4 f 5-5 Goto FSBL: 0x80008000 Welcome to FSBL …

REG32(VO_SW_SEC_1)=01C00000 [FSBL] Secure: 0x0000BEEE [FSBL] DCache Enable: 0x00000000 [FSBL] SVP = N ********** FW_TYPE_BOOTCODE ********** FW Image to 0x00100000, size=0x00080BA0 (0x00180BA0) FW Image fr 0x881313E8 kmcp_bypass copy audio bin FSBL: plat_gic_setup FSBL: plat_gic_setup_percpu FSBL Jumps to LK

U-Boot 2015.07 (May 13 2020 - 17:12:53 +0800)

CPU : Cortex-A53 Quad Core - AARCH64 Board: Realtek QA Board DRAM: 1 GiB Watchdog: Disabled mapping memory 0x20000000-0x40000000 non-cached flushing dcache successfully. nor flash id [0x00ef4018] sector 256k en: 0 sector 64k en: 1 sector 32k en: 1 sector 4k en: 1 page_program : 1 max capacity : 0x01000000 spi type name : WINBOND_W325Q128BV_128Mbit MMC: Initialize eMMC in traditional mmc flow. RTD1395 eMMC: 0 rsp[0]=0x15010038, rsp[1]=0x47544634, rsp[2]=0x52064546, rsp[3]=0x49abc8af The cid_val is 15. rsp[0]=0xd0270132, rsp[1]=0x0f5903ff, rsp[2]=0xf6dbffef, rsp[3]=0x8e40400d mmc->version=0x40000000 version=0x00000004 [LY] cardtype=57, mmc->card_caps=0f [LY] freq = 00464388, clk diver = 00000080 [LY] speed up emmc at HS-200 [LY] HS-200 bus width=2 [LY] mmc->boot_caps = 20b TEMP TX_WINDOW=0xfffffff3, TX_best=0x12 RX_WINDOW=0xffffe0ff, RX_best=0x1a TX1_WINDOW=0xffffffe1, TX_best=0x12 [LY] hs200 : 0 [HC] ERASE Unit Size = 524288 bytes [HC] WPG_SIZE = 8388608 bytes Device: RTD1395 eMMC Manufacturer ID: 15 OEM: 100 Name: 8GTF4 Tran Speed: 200000000 Rd Block Len: 512 MMC version 4.0 High Capacity: No Capacity: 7.3 GiB User Capacity: 7.3 GiB Boot Capacity: 4 MiB RPMB Capacity: 512 KiB Bus Width: 8-bit Speed: HS200 SD: SD device index# 0 Factory: SD ------------can’t find tmp/factory/000BootParam.h [ENV] read_env from factory failed Using default environment

*** Warning - bad CRC, using default environment

[BPI] set dram dtb is 1GB In: serial Out: serial Err: serial GUID Partition Table Header signature is wrong: 0x0 != 0x5452415020494645 get_partition_info_efi: *** ERROR: Invalid GPT *** GUID Partition Table Header signature is wrong: 0x0 != 0x5452415020494645 get_partition_info_efi: *** ERROR: Invalid Backup GPT *** ------------can’t find tmp/factory/hdmitx_format.bin ------------can’t find tmp/factory/video_rpc.bin tv_system=25 mode=1 Net: Realtek PCIe GBE Family Controller mcfg = 0024 dev->name=r8168#0 Checking default environment Hit Esc or Tab key to enter console mode or rescue linux: 0 ------------can’t find tmp/factory/recovery ------------finished reboot_action ======== Checking into android recovery ====

==== start load bootcode from SD ===== SD: try to boot from SD mmc->scr[0]=2b58000,mmc->scr[1]=0 SD: init done, no error SD: capacity 7872512 sectors(0x782000), (3844 MB) CMD[fatload sd 0:1 0x00030000 /bananapi/bpi-m4/linux/u-boot-bpi-m4.bin] reading /bananapi/bpi-m4/linux/u-boot-bpi-m4.bin ** Unable to read file /bananapi/bpi-m4/linux/u-boot-bpi-m4.bin ** CMD[fatload sd 0:1 0x00030000 u-boot-bpi-m4.bin] reading u-boot-bpi-m4.bin ** Unable to read file u-boot-bpi-m4.bin ** CMD[sd read 0x00030000 0x50 0x430] SD read: dev# 0, block# 80, count# 1072 … do sd_ops MMC_READ 1072 blocks read: OK [WARNING] bootcode seem is not valid, first 4 bytes: 00 00 00 00 CMD[fatload mmc 0:1 0x00030000 /bananapi/bpi-m4/linux/u-boot-bpi-m4.bin] ** No partition table - mmc 0 ** *No partition table, try part 0 again! *** Unrecognized filesystem type ** CMD[fatload mmc 0:1 0x00030000 u-boot-bpi-m4.bin] ** No partition table - mmc 0 ** *No partition table, try part 0 again! *** Unrecognized filesystem type ** CMD[rtkemmc read 0x00030000 0x50 0x430] [WARNING] bootcode seem is not valid, first 4 bytes: 00 00 00 00 Enter console mode, disable watchdog …


The only things that I can not undestand is why if I connect first HDMI cable and than USB-C power cable the board won’t power up, if I connect power cable first and than HDMI the board power up normally.

don’t know much about hdmi issues all I can tell you is rule out any hardware incompatibilities first, most importantly, make sure the power supply is pumping out enough juice to support this board as this may be the culprit, I use a 3mah. Move onto other things like try another hdmi cable, if that doesnt work try on a different monitor, try without any usb peripherals connected such as keyboard or mouse. if neither option works then it’s either a hardware problem with the bpi or a software issue.

Personally those homebrew images are a bit hit and miss, my board only registers1 1gbp when using those whereas the official images are configured correctly, it took me about a month to realised what was causing it. it’s the way in which the config file and dts kernel is configured in the boot partition is configured. I think, easily resolved but had me stumped.

On a normal pi you have config options, within the config file for various HDMI settings, this was introduced to overcome some of the HDMI incompatibility issues, perhaps some of those codes may work in the bpi uenv file within the boot partition, or maybe there are some display options within raspi-config that can be adjusted if your running rasbian and have ssh access.

to me it looks like it’s struggling to boot from bin file which has me thinking your running a dodgy image, so I would try a different one, see what result you get.

Unfortunately nothing is simple until you understand iwhy it’s misbehaving, then it’s going to be simple.