Banana Pi R-64 and WiFi

Hello all,

I am just despairing regarding the R64 and WiFi with the image “bpi-r64_bullseye_newatf_5.15_incomplete.img” …

I installed this on my R-64 and I can’t activate the 2.4 GHz nor the 5 GHz module in any way. It takes hours until the “WLAN0” shows up under “ifconfig -a”. The 5 GHz module I could not see so far. What is possibly wrong here? What does not work here? Should I rather go to the older version of the image?

Best regards from Berlin

i’m not sure i have tested wifi in this image as the name contains “incomplete”, it was a start for having an acutal base. i guess wifi-firmware is missing…

i wonder why it “takes hours” instead of simply “not working”.

maybe wifi driver is unstable here as i used a very early 5.15 there. try upgrading kernel to a recent 5.15.

and you have not answered to my questions here:

Hey Frank, It’s really not my style not to answer a question. I somehow missed your question. I apologize for that.

  1. Question over Debian Bullseye image

dmesg | grep -i ‘mt76’ [ 0.000000] Kernel command line: board=bpi-r64 console=ttyS0,115200n1 earlyprintk root=/dev/mmcblk1p5 rootfstype=ext4 rootwait service=linux debug=7 initcall_debug=0 androidboot.hardware=mt7622 swiotlb=512 [ 1.300117] rtc_mt7622 10212800.rtc: registered as rtc0 [ 1.305398] rtc_mt7622 10212800.rtc: setting system clock to 2000-01-01T00:00:00 UTC (946684800) [18709.463637] mt7622-wmac 18000000.wmac: Load eeprom: /lib/firmware/mediatek/mt7622-wmac_rf.bin [18709.473273] mt7622-wmac 18000000.wmac: Load eeprom OK, count 1024 byte [18709.518245] mt7622-wmac 18000000.wmac: HW/SW Version: 0x8a108a10, Build Time: 20190801210006a [18709.568789] mt7622-wmac 18000000.wmac: N9 Firmware Version: reserved, Build Time: 20190801210351

  1. Question over Debian Bullseye image The external WiFi - Card is installed on cn25, so like your informations…

  2. Question over Debian Bullseye image If I try “lspci” there are no output on my screen

  3. Kernel - Version At the moment, I had the following kernel installed: 5.15.0-bpi-r64-main I don’t know, if this is a new 5.15 - Kernel or not…

  4. takes hours instead of simply “not working” Well, the reason is, that sometimes I´ve got the WLAN0 - Interface if I reboot the router. At the moment, it is not working.

Best regards

Z. M.

Hey Frank,

NOW - my system is up since: 19:40:55 up 5:47, 2 users, load average: 0.14, 0.26, 0.31

AND now, I had the Interface: 14: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000 link/ether 00:0c:43:26:60:00 brd ff:ff:ff:ff:ff:ff inet6 fe80::20c:43ff:fe26:6000/64 scope link valid_lft forever preferred_lft forever

BUT! No IP - Adresses is bind to this Interface, etc. And I don’t know, what kind of problems that this is… Best regards

Z. Matthias

which card do you use? i know about some current limits which prevents wifi6-cards to be shown up

I use this card additional: MTK MT7615 on cn25 - Slot…

your dmesg above says you have enabled the mt7622 wmac-wifi which firmware gets loaded (which i guess is the wlan0). As it is same driver this is not missing. so basicly the card is not recognized.

if lspci shows nothing (no controllers too) i guess there is something with pcie wrong…maybe looks in dmesg about pcie mapping

dmesg | grep -i ‘pci’ [ 0.064211] PCI: CLS 0 bytes, default 64 [ 1.559266] mtk-pcie 1a143000.pcie: host bridge /[email protected] ranges: [ 1.565889] mtk-pcie 1a143000.pcie: Parsing ranges property… [ 1.571785] mtk-pcie 1a143000.pcie: MEM 0x0020000000…0x0027ffffff -> 0x0020000000 [ 1.680301] mtk-pcie 1a143000.pcie: Port0 link down [ 1.688710] mtk-pcie 1a143000.pcie: PCI host bridge to bus 0000:00 [ 1.700970] pci_bus 0000:00: root bus resource [bus 00-ff] [ 1.706465] pci_bus 0000:00: root bus resource [mem 0x20000000-0x27ffffff] [ 1.713346] pci_bus 0000:00: scanning bus [ 1.718561] pci_bus 0000:00: fixups for bus [ 1.722751] pci_bus 0000:00: bus scan returning with max=00 [ 1.728719] mtk-pcie 1a145000.pcie: host bridge /[email protected] ranges: [ 1.735295] mtk-pcie 1a145000.pcie: Parsing ranges property… [ 1.741147] mtk-pcie 1a145000.pcie: MEM 0x0028000000…0x002fffffff -> 0x0028000000 [ 1.849483] mtk-pcie 1a145000.pcie: Port1 link down [ 1.854563] mtk-pcie 1a145000.pcie: PCI host bridge to bus 0001:00 [ 1.860756] pci_bus 0001:00: root bus resource [bus 00-ff] [ 1.866249] pci_bus 0001:00: root bus resource [mem 0x28000000-0x2fffffff] [ 1.873131] pci_bus 0001:00: scanning bus [ 1.878315] pci_bus 0001:00: fixups for bus [ 1.882507] pci_bus 0001:00: bus scan returning with max=00

As already briefly written, it happens that the system displays the WLAN0 after a very long time, before that it cannot be found.

Therefore, I do not know how to better narrow down this error… What is the reason why this is not visible immediately after restarting the router… AND! Why it does not want to bind an IP - address to it afterwards.

This is somehow not apparent to me at the moment…

It is useful to test this image: r64_buster_sd_mt7531.img for using the 5 GHz - Module?

Best regards

Z. Matthias

Yes of course you can try the older image. Afair mt7615 was working on r64.

I cannot give a fast and simple answer why it is not working.

My guess is that 5.15.0 contained a bug in pcie. You see that controller is successfully probed but port link is down.

Please mark code/logs as such by using the “<>” button for better readability.

Btw. Current 5.15.y is 5.15.40 :slight_smile:

Thank you very much. But, how can I get the newest Kernel? Or did you have on Image with this kernel?

My kernel repo is at 5.15.33,you can get a compiled image on its releases page

Just download the tar.gz for r64, unpack the content of the folders into the right partition (maybe change name of uImage) and add a line pointing to the new kernel file in the uEnv.txt

…and I can just unpack the data “bpi-r64_5.15.33-main.tar.gz” on the router first?

And where do I find this “uEnv.txt” - file? Is a recompile of the system necessary?

no, uenv.txt is on BPI-BOOT-partition (where the uImage needs to be extracted), if none exist just create one in same folder like the uImage or in the root of this partition

modules go to BPI-ROOT like the folder in the tar-file

Well, I think this is not so easy, or?

Under </boot/bananapi/bpi-r64/linux> if found these files:

<5.15.0-main.itb> <uEnv.txt>

If I understand you right, I should install all files and /or directory: <bpi-r64.itb> <uImage_nodt>

and after them I change the <uEnv.txt> File, or?

from i installed all file to </>, or?

Ah,right,r64 uses itb file, so copy itb from tar to /boot and modules to /

Tar file contains folders BPI-BOOT (content for /boot in running system) and BPI-ROOT (/)

You can also replace existing itb (after a backup) so no change in uEnv.txt is needed

Thanks, so lot… I installed it now and reboot it. Now, the kernel is: <5.15.33-bpi-r64-main>

BUT! with <dmesg | grep -i ‘pci’ > or <dmesg | grep -I ‘mt’> the output is empty! WAN & LAN /LANBR0 is working…

I guess you missed copying the modules to /lib/modules

I guess, that I have done this…