Banana Pi M3 Ubuntu 16.04

Hi, I want to install Ubuntu 16.04 to Banana Pi M3 . But when I download it’ s image from here, I couldn’ t unzip it. Because image had broken. Can anyone send me Ubuntu 16.04 with GPU image link? Thank’ s a lot.

it is not broken, we have test it, note ,if you unzip it under winodows ,please note your filesystem, if it is FAT32 ,have 4G file size limited, you can try on linux.

Sorry to giving answer late. I tried again. And I took same error.

I tried open zip file. It’ s cannot open. And when I tried to unzip from console, Image flie exported with error.

file named “-” is the image of the recording - I had the same problem. :slight_smile: If you have the opportunity to run the installation on Windows?

I tried windows first. When I get that error, I tried Ubuntu again. But it didn’ t work. Am I doing something wrong?

Try this: :slight_smile: I hope it will help :slight_smile:

1 Like

I bought a banana pi bpi-m3 several months ago (before the end of 2015) - I have not been able to use it since the day I bought it. I came to the conclusion that there were problems with all linux images. So I put the board aside, hoping that at some point the problem would be rectified. It is now June 2016, and a couple of weeks ago I received an email (newsletter) that stated that new linux images for banana pi bpi-m3 were available. So, out came the board, and I downloaded the linux image that I wanted. When I tried to unzip the image, I found that it didn’t work. My computer had no idea about the name of the file that was inside the zip file, it also had no idea what type of file it was either. The only thing my computer could tell me was that the contents of the zip file was 7.8GB. My immediate reaction was that the downloaded zip file was corrupt. I repeated this process a number of times, but I got the same result every time. So, I gave up on this image and moved on to one of the others - same thing every time. Same result every single time - I now believe that every one of these “new images” are corrupt. I have tried all of the above on a Windows computer, a Linux computer and an Apple Mac - each time I get exactly the same result. Please tell me what is wrong - I still have not been able to use this board from the day I bought it - more than 6 months now


this is a video for how to install kali linux , all image is same way burn to SD card ,you can try again:

They don’t test their stuff and they use some advanced ZIP tool that produces ZIP files that do not work on most platforms. On OS X for example you would need Keka or ‘The Unarchiver’ since the ZIPs famous ‘Team BPi’ provides are incompatible with normal/common unzip programs.

Then you end up with a file that is called ‘-’. So you have to rename this file to something like ‘crap.img’. Then you’re able to burn the image but be prepared that famous ‘Team BPi’ doesn’t care that much about what they do so they are able to burn an image that is just 7.3GB large to an SD card of 16 GB size, fiddle then around there and create an image of the whole 16 GB afterwards (which you can’t burn on most other 16 GB cards without an error message since the image contains over 8 GB unused junk).;

BTW: Other vendors populate the eMMC on a board with something like Android so you know that your board is able to boot. But not ‘Team BPi’.

And BTW: Since the M3 is such a weird design it will take ages until community will provide good OS images for this board (if ever)

oh ,i see , you work together with orange pi, so you always attack us , you even not know how to do a hardware .

yes ,orange pi 2E , you are very like it ??? ,please add base anti-static function on hardware . and do WIFI test in LAB, and give Validation test report at first, this is base test for a product.

@sinovoip: Thx for modifying my post and deleting the link. So you confirmed that it happened that way. Thank you for this confirmation. Keep on suffering! :slight_smile:

yes. i keep all message except orang pi 2E link. i do not like you attack us and advertise others . this is just why.

if you want ubuntu 16.04 run on 8G emmc flash, you can use this image, it is newer test image for BPI-R1, and use bpi-bootsel , it can run on BPI-M3, for we are in china ,it is hard update image to google driver. too slow.:slight_smile:


My name is Rob - i’m a few messages up under the name “stat”. This is my story.

My first single board computer that I bought was a Raspberry Pi B+. I brought that board home, got onto the Raspberry Pi website, downloaded the linux image that I wanted, formatted my micro SD card, unzipped the image and burned that image to a bootable micro SD card - all within an hour.

I put the card into my Raspberry Pi, connected the cables, applied power and in no time at all I had linux running on my computer. The whole thing was easy, straight forward and worked perfectly.

In fact it was so easy that, when the Raspberry Pi 2 came out I bought one of them too. And, because the Pi 2 was so easy and straight forward, I also purchased a Raspberry Pi 3 and Raspberry Pi zero when they were released. I bought all of these boards because every one of them worked perfectly straight out of the box, and the process of getting their images onto micro SD cards worked every time.

While I have been using my Raspberry Pi’s, I also bought an Odroid C1. I had the same experience with the C1 that I had with my Raspberry Pi’s, and because I did, I bought an Odroid C1+, and then an Odroid XU4 and finally an Odroid C2.

So now, I have 8 fantastic boards that I have purchased from Raspberry Pi and Odroid. In December 2015 I bought a 9th board - a Banana Pi BPI-M3. In Dec. 2015 I downloaded in turn, all of your linux images. Why did I download all of your images you may wonder - but the reason is that I downloaded the first image an it didn’t work so I moved onto the next one and the one after that. So I downloaded all of them because they didn’t work. Not one single linux image was I able to download and unzip. By this stage I was a little more than disappointed, I was getting angry. You know, a few minutes on the official banana pi forum showed that I was not alone in feeling angry - many many people were expressing their anger at you too, Sinovoip. And many many people are continuing to express their anger towards you.

It is now the 7th of June 2016 and about 2 weeks ago I received an email from you that stated that there were new operating system images on your website. So I pulled my Banana Pi BPI-M3 board out and downloaded the linux imaged that I wanted and guess what, just like in December 2015 I could not unzip this compressed image file. It didn’t matter whether I tried a Windows computer or an Apple Mac or a Linux computer not one of these “new images” could be unzipped. Looking inside the compressed image files (on all 3 computers) showed a file name of “-”, no file type but had a file size of 7.8GB (and this was the case for every compressed linux image on your website. occasionally, when I tried to unzip an image - all that happened was that the file changed into a file with a “cpgz” extension.

So, like I said, it’s the 7th of June 2016 and my little banana pi bpi-m3 board (6 months after I bought it) has not seen a micro SD card with a bootable linux image. All you have to do is read your own forum for this board - I am not the only one having these problems.

When I try to download an image a link sends me off to Google Drive and Google Drive gives me this wonderfull message “Whoops. There was a problem with the preview”. This gives you a lot of confidence doesn’t it. I you click on download Google Drive comes back with fabulous one this time, “Google Drive can’t scan this file for viruses”. Encouraging isn’t it.

You know, the bpi-m3 might be a really good board, but you let it down with your poor support and really bad image files. No wonder there are so many people on the bpi-m3 forum that are so so angry.There is no point you getting angry with tKaiser as above - he/she is just like many other people who bought your board in good faith and you, as a company, haven’t delivered.

If your company wants to play on the world stage then take a good long look at Raspberry Pi and Odroid and see how they are doing it. Their boards are brilliant, their OS image files are just so easy to download, unzip and burn to bootable micro SD cards. It’s easy to see why these companies are doing so well - just read their forums for their boards you will soon realise why they are successful. I am not being negative towards you (the company), I’m stating simple facts and if you don’t lift your game - then your company will fail.

P.S. you posted a message above for an ubuntu 16.04 image - tried that, it was just like all your other images, it didn’t work. I could not unzip the file - in fact trying to unzip the file turned it into a file with a cpgz file extension.


You’re on OS X and try to use the default mechanism to unpack a ZIP from @sinovoip which does not work. At least I told them a few times, others did, but @sinovoip never gives a shit and instead of using a more compatible ZIP tool they now ‘enhanced’ their processes so that inside the ZIP archive is a file with a weird name. Also their images are way too large (filled with useless junk) so that poor Windows users relying on FAT 32 have not the slightest chance to burn them.

This is all known since ages but @sinovoip simply doesn’t get the idea what might be wrong with that. That being sad you could use ‘The Unarchiver’ on OS X to successfully unpack this OS image (this is also known by @sinovoip but instead of prividing this information at the release notes every OS X user has to fail). But believe me it’s not worth the efforts, usually not even an ‘apt-get upgrade’ will work since their images come with a rootfs that’s almost 100% full (and again: they get these complaints on a regular base and simply don’t give a shit).

It’s somewhat unbelievable that they do not even think about what might be wrong with this approach. But maybe they’re convinced that all their customers are morons anyway and think they provide perfect OS images but the people here in the forum are just too dumb to use it?

BTW: In case they provide a rather huge OS image (happened with the same 16.04 image for M2+) here is some information how to deal with it: BPI-M2+ new image:Ubuntu mate-16.04_Xenial mpv 1080p-bpi-m2p_preview 2016-05-05

Hi tkaiser

Thanks for the info. I think that I’m just about at the point where I will write the board off - I think I agree with you that it’s probable not worth the effort. I enjoy using the Raspberry Pi’s and the Odroids (particularly the XU4 and C2), so I might just leave it at that.

It’s always good to meet nice people on forums, thanks for your posts, and you take care

best regards


sorry , when you unzip this file with winrar . it show a file “-” name , it can burn to SD card direct, or just change “-” name to “xxxxxxxx.img” . it is easy to do .

yes , we need to do this work by ourself , but we have update many image to google driver, as you know ,we are in china ,government limite to login google driver ,we must use VPN to login ,speed is too slow. it is hard to update a big file to google driver , 1G file ,we need one day to update to google driver.

sorry for this mistake.

we use linux standard zip commond to create this image ,maybe limited file name long on windows ,just need change “-” name to “xxxxxx.img” , or direct burn “-” file to SD card and emmc.

BTW: user also can bpi-copy to create image from SD card , or burn image to SD card &eMMC ,it can save your time.:wink: