Banana Pi M3 reboot issue

I just got the new banana pi m3 with new samsund micro sd card and the power supply on micro usb… I just write arch linux img on it try to boot up but it wont worked so i checkd the sd card and check sums but it is correct i dont know what is wrong but banana pi is just keep rebooting - all leds are blinking up for a moment and screen seems to have some output - banana pi logo and then just it is rebooting and same againg… Bdw I tried 3 different power suppliers and still won’t worked all was 5v and 2A (sorry for any mistake in message Im just not very good at English (not my country))

are you try other image ,it with same issue???

I try arch(7 times), kali(5times) and debian(one time)… Now i ordered dc-in power supply to check is it the usb fault or somthing else… It would be helpful to know what is happening on my board when i start it up and what is the specyfic sequence on it and how it cloud be seen by normal user… Because when i hok up monitor to hdmi there is some video output for a moment a a logo with link on it…

Here I uploaded video on YouTube (in time laps)… Can you help me with this ?

Hello Community. :slight_smile:

I’m sorry to say, but I’m struggling with exactly the same Issues.

Here are my details:

Power: First try with Micro USB-OTG, later with Barrel Jack AppleCharger for Ipad, Iphone, other charger (all minimum: 5V 2A )

I also tried several SD-cards with several images (All HC1 Class10) I followed exactly the Instructions and created the sd-cards with dd (They work with my other Raspberry Pi’s without any problems)

The Banana shows up the Splash screen, all LED’s are on, and then it turns off.

I tried it with several possibilites: without any plugged in cable just ethernet just HDMI and Keyboard (HDMI>DVI AND HDMI-HDMI) (Logo is showing) …

Sadly I faced excatly the bahaviour as in the video above.

I bought 2 Banana’s and no one is booting.

I hope someone can give me a hint :wink:

Thank you.

Kind regads,



so I plugged in both - a Micro USB on the USB-OTG Port and a Barrel Jack. both powered from an Anker USB PowerHub. (5V 8A)

and it’s working…

can someone relate and/or explain)

kind regards,


it not need 5V/8A ,just 5V/2A working fine, please check your adapter line ,many adapter line just support 5V/1A

I think its about power stability… You should consider making a some stabilization - like a power capacitor or something like that to purify power supply - and also give more power to the board it self… And sell the banana pi with the power supply - just to don’t lose clients on stiupid power problems… That is my advice but I will check that the doubled power supply is the real solution to this problem when I finally get my package (7 hours) with the cable and the heat sinks :slight_smile: hope it will work

The Charger is able to provide up to 5V/8A - that doenst mean that the board is using it. It’s about Power consumption and stuff like basic electronics :wink:

and as i wrote i tried many different types of Chargers… EVERY other sinlge-board-compuer I own is working like a charm.

Ok problem solved !! Power supply over barrel jack 5V 2.5A it is all

I think you should give a power supply with the board (you can make it a little bit more expansive) or just sell the starter kit (board + power supply and case or something) that would be nice

I can confirm. Just bought an adjustable power suply (3-12 VDC 2,25A) and the Pi is working.

you really should update the technical specs that 5V 2A is NOT enough

This thread is over a couple of years old and is still very needed.

@sebhoff, thanks for your endurance to solve the problem. This motivated to solve mine. Many forum entries as well as other goolgle searches say that 5V 2A should be enough (and may direct the investigation away from power source problems).

Maybe 5V 2A is enough, maybe not. My guess that it depends a lot how fast those 2A can be delivered. Because on the boot, those 2A need to be delivered very very vast for a very very short period of time. Millisecond or so. I have tried to measure with the multimeter, and I cannot tell how much for how long it needs that 2A supply. It is like a peak: it goes up, and immediately goes down to around 500-700mA. And then it stays there. Quite an annoying problem.

Another annoying problem was that ssh was not enabled by default. To enable that I needed to edit some config files. To edit config files I needed to login to the device, but hdmi was not working for me. I ended up getting an old image, where ssd was enabled by default, upgrading it to scratchy, and re-enabling the hdmi

My hdmi pars are: /boot/firmware/bananapi/bpi-m3/linux

auto_hpd = 0 ;---------------------------------------------------------------------------------- [boot_disp] output_disp = 3 output_type = 5 output_mode = 1