[Banana Pi M2 Zero] How to enable UART?

I’m using Banana Pi M2 Zero with Armbian Debian GNU/Linux 10 (Buster). Compiled the image myself with the latest source code using the armbin/build repository.

I want to be able to do serial communication on pins 8 and 10.

I’m looking for something to appear at /dev/ttyAMA0, so I can communicate with it.

I saw some other forum posts which mentioned it’ll happen on /dev/ttyS0 , however even that is not happening. The serial communication is working via FTDI (using the USB side connected to the Banana Pi), which indicates there is no problem with the other device. This is what the configuration looks like using “sudo minicom -s”.

| A -    Serial Device      : /dev/ttyS0                                |
| B - Lockfile Location     : /var/lock                                 |
| C -   Callin Program      :                                           |
| D -  Callout Program      :                                           |
| E -    Bps/Par/Bits       : 115200 8N1                                |
| F - Hardware Flow Control : No                                        |
| G - Software Flow Control : No                                        |
|                                                                       |
|    Change which setting?                                              |
        | Screen and keyboard      |
        | Save setup as dfl        |
        | Save setup as..          |
        | Exit                     |
        | Exit from Minicom        |

I have enabled “uart1” using “sudo armbian-config -u” -> System -> Hardware.

Connecting Rx, Tx on the pins 8 and 10 also does not show up in “dmesg”

How do I go about debugging the issue or finding the root cause of the problem?

Many thanks!

you may need to enable UART3 with armbian-config

serial console on pins 8(TxD) and 10(RxD) is mapped to /dev/ttyS3 (UART3) on banana PI M2 Zero


Thanks @bontango. It worked!