Banana Pi M2 Ultra not working on Linux/Android

Hello there. I just got a Banana Pi M2 Ultra with Allwinner A40i SOC and I installed lots of Linux distros available from the official wiki, on a 32gb U1 SD card, however, everytime I boot into a desktop environment, it simply halts the entire system. I have tried Android as well, however, the screen is glitchy, almost impossible to navigate. I also tried Armbian as well(Kernel 5.15 and 5.19, Jammy version from Github), and they didn’t work at all. I am powering the system using micro USB and a 10-15W phone charger, which should be plenty of power for the board. Is there any available solution that would work on the A40i model? Thanks.

Would you like to try my using method?

Prepare to develop:

a. 8GB or more SD card

b. Windows/ Linux / MAC os PC

c. USB-Serial interface

d. SD card reader

  1. Downloading newest image on wiki on PC:https://wiki.banana-pi.org/Banana_Pi_BPI-M2U#Ubuntu
  2. Installing Balena Ethche(burning tool) on PC: https://www.balena.io/etcher/
  3. Installing the SD card in card reader, then installing the card reader in PC. (Please confirm SD card have no any other files in it. If not, you have to format the SD card)
  4. Opening your Balena Ethche, please choose” Flash from file” image And choose the image which you downloaded on PC

You can try 2020-04-19-ubuntu-16.04-server-bpi-m2u-sd-emmc.img.zip

https://download.banana-pi.dev/d/ca025d76afd448aabc63/?p=%2FImages%2FBPI-M2U%2FUbuntu16.04&mode=list image

  1. Go on the next steps, choose you sd card

image image 7. Choose Flash

image

image 8. Finished image

  1. Removing card reader on PC

  2. Installing SD card on M2U, connecting display (1080P/720P) via HDMI port.

  3. Connecting 5V/2A micro-usb power adapter. And power on.

It works so far. It doesn’t have a desktop environment however, but at least it works so far. Is it possible however to install one via terminal(with an internet connection)? If so, can you recommend me one? Thanks!

https://github.com/armbian/community Search for “Banana Pi M2 Ultra”

They should work … Where it stops? Can you attach serial console? This is worth fixing …

Should I flash the sid or the jammy version? Also, how do I get the serial console, so that I could attach it here?

https://linux-sunxi.org/UART

Both will work or both will fail.

Well, the OS failed to boot, it only shows me red light at the place where RGB is supposed to show. I am mentioning that I flashed this image on the SD card, and I could browse it without problems on Fedora.

Image is: Armbian_22.11.0-trunk_Bananapim2ultra_sid_edge_5.19.10_xfce_desktop.

Also, at the moment I don’t have an USB to UART converter cable. Can a normal micro USB to USB cable be used for to connect to a serial console as well?

Can I use Arduino Uno R3 as a USB-to-UART converter? I see that it has entries for TX and RX, which should make it capable of such a thing. Update: I managed to make it work as a USB-to-UART converter. Unfortunately, however, this didn’t solve the issue, as the Pi randomly freezes itself when trying to update the software(in this case Ubuntu 16.04 Server), or even closing software like let’s say top(by pressing ctrl and c), with no error logs whatsoever.

I also tried Ubuntu 16.04 Mate, but it didn’t start up at all. Is it the OTG based power supply’s fault? All I got as output from the TTL is:

U-Boot 2014.07 (Nov 11 2017 - 19:07:47) Allwinner Technology

uboot commit : 8
i2c_init ok
[      0.446]pmbus:   ready
[      0.465]PMU: AXP221
[      0.465]PMU: AXP22x found
[      0.466]PMU: dcdc2 1160
[      0.468]PMU: cpux 1008 Mhz,AXI=336 Mhz
PLL6=600 Mhz,AHB1=200 Mhz, APB1=100Mhz  MBus=400Mhz
set power on vol to default
dcdc1_vol = 3300, onoff=1
dcdc2_vol = 1160, onoff=1
dcdc3_vol = 1100, onoff=1
dcdc4_vol = 1100, onoff=0
aldo1_vol = 2800, onoff=0
aldo2_vol = 1500, onoff=1
aldo3_vol = 3000, onoff=1
dc1sw_vol = 3000, onoff=0
dc5ldo_vol = 1100, onoff=0
dldo1_vol = 3300, onoff=0
dldo2_vol = 3300, onoff=0
dldo3_vol = 3300, onoff=0
dldo4_vol = 2500, onoff=0
eldo1_vol = 2800, onoff=0
eldo2_vol = 1500, onoff=0
eldo3_vol = 1200, onoff=0
gpio0_vol = 3300, onoff=0
gpio1_vol = 1800, onoff=0
find power_sply to end
vbus exist
BPI: bpi_boot_init_gpio ...
set pin for gpio_pin_1
set pin for gpio_pin_2
set pin for gpio_pin_3
set pin for gpio_pin_4
[     0.33]HELLO! BOOT0 is starting!
[     0.37]boot0 commit : 2320b4e28f694a40302a75531ea057ca7fcc0074

[     0.44]boot0 version : 4.0
[     0.47]set pll start
[     0.51]set pll end
[     0.87]rtc[0] value = 0x00000000
[     0.90]rtc[1] value = 0x00000000
[     0.93]rtc[2] value = 0x00000000
[     0.97]rtc[3] value = 0x00000000
[     0.100]rtc[4] value = 0x00000000
[     0.104]rtc[5] value = 0x00000000
[     0.107]DRAMC IS FOUR
[     0.109]DRAM BOOT DRIVE INFO: V1.1
[     0.113]the chip id is 0x00000001
[     0.116]the chip id is 0x00000001
[     0.120]the chip id is 0x00000001
[     0.123]the chip id is 0x00000001
[     0.127]the chip id is 0x00000001
[     0.134]PMU: [     0.135]AXP221
[     0.137]ddr voltage = 1250 mv
[     0.144]PMU: [     0.145]AXP221
[     0.147]ddr voltage = 1250 mv
[     0.158]PMU: [     0.159]AXP221
[     0.161]ddr voltage = 1500 mv
[     0.172]DRAM CLK =576 MHZ
[     0.174]DRAM Type =3 (2:DDR2,3:DDR3,6:LPDDR2,7:LPDDR3)
[     0.180]DRAM zq value: 0x003b3bfb
[     0.185]DRAM SIZE =2048 M
[     0.189]DRAM simple test OK.
[     0.192]dram size =2048
[     0.194]rtc standby flag is 0x00000000, super standby flag is 0x00000000
[     0.202]card no is 0
[     0.205]sdcard 0 line count 4
[     0.208][mmc]: mmc driver ver 2016-07-01 15:30
[     0.212][mmc]: sdc0 spd mode error, 2
[     0.225][mmc]: Wrong media type 0x00000000
[     0.229][mmc]: ***Try SD card 0***
[     0.239][mmc]: HSSDR52/SDR25 4 bit
[     0.243][mmc]: 50000000 Hz
[     0.245][mmc]: 29819 MB
[     0.248][mmc]: ***SD/MMC 0 init OK!!!***
[     0.354]Loading boot-pkg Succeed(index=0).
[     0.358]Entry_name        = u-boot
[     0.377]Ready to disable icache.
[     0.381]Jump to secend Boot.