Banana Pi M2 Ultra - Can't boot from EMMC if microSD inserted


I have a banana pi M2U and I’m trying to boot with the SD card inserted (to use it as a data disk). But unfortunately i’m unable to get my image to boot if the SD card is in the slot (it keeps restarting in loop). There is nothing written on the card, I used dd if=/dev/zero of=/dev/mmcblk1 Bootstrap=1M and I also reformatted it). If I insert the SD card after the boot is done, there is no issue (but it’s not my intended usage).

The image I’m using on the EMMC is this one : 2017-08-27-debian-9-stretch-lite-preview-bpi-m2u-sd-emmc.img.

I found some topics (for my card or similar ones) about it but nothing solved my issue:

Here a screenshot of the banana pi booting with the SD card inserted

1 Like

Maybe this information will help:

I used this information for Booting with eMMC and with or without SD-Card insert

Thank you for your suggestion, but apparently the file (/boot/script.bin) doesn’t exist:

root@bpi-iot-ros-ai:/home/pi# ls -al /boot/script.bin 
lrwxrwxrwx 1 root root 22 Apr 30  2016 /boot/script.bin -> bin/bananapim2plus.bin

I tried to find where this file was located but I didn’t get any result (find / -name "bananapim2plus.bin" returns nothing)

@sinovoip Have you any tip to give to me so I can solve this issue? :slight_smile:

you need total format your SD card ,

bpi-bootsel BPI-cleanboot-8k.img.gz /dev/sdX

Thanks for info, sadly I’m still experiencing the error though (the path of the drive isn’t something /dev/sd* but /dev/mmcblk1, but I guess it shouldn’t be a problem).

If the SD card can load a ‘boot loader’ at power on, and allow user to select a boot device, it should solve much of the boot problems.