Banana Pi M1 won‘t boot


I have a problem with my BPI I installed over 6 images but none of the boot. After that I changed the power supply to a 2A 5V.The first problem was solved.I booted android the first time everything went without problem after i disconnected the charger it doesn‘t boot anymore.Just the red light just lights up.

please see online wiki :

thanks for the answer but tried everything what was written on the site and didnt have success it still dont boot up. Can you give me the link to newest image for android hdmi for bpi m1

keeping power on, and follow the steps:


I recently (2~3 months ago) acquired BPi-M1 boards at a promotional price from a shop wanting to get rid of them.

Seems like they have some problem with the power supply. I got mine working / booting properly after using both micro USB connectors connected to 3-port USB charger from Ikea ( )

As I am an electronician (hardware) guy too, I plan to modify the hardware on those boards to fix this problem once for good. :wink:

Apart this little issue, the board is working fine as a LEMP stack Web server under Arch Linux ARM ! :wink: