Banana pi does not start

I bought a banana Pi, installed Armbian on the SD, and my Banana Pi doesn’t start, the Power led is blinking twice, and nothing happens on the Screen, the charger is in the correct parameters. Thank you very much in advance.


I got a BPI-M2 Zero yesterday and I installed 2020-04-28 update, Debian 9, Rasbian Stretch mentioned at It did work and I got stable WiFi I after a few upgrades.

Next I would try Armbian …

Which version or flavor of Armbian have you tried ? Nice to know what I shouldn’t download


I downloaded the Hirsute version and installed it on a spare sd card.

So fare it works well on the “Banana Pi M2 Zero” I received to days ago …

Armbian 21.08.5 Hirsute with bleeding edge Linux 5.15.2-sunxi

*******@bananapim2zero:~$ uname -a Linux bananapim2zero 5.15.2-sunxi #trunk.60 SMP Wed Nov 17 04:42:13 UTC 2021 armv7l armv7l armv7l GNU/Linux

Update 2 …

For the record the sdcard I used was a Scandisk Ultra 32GB …

A quick “speed” test

hdparm -t /dev/mmcblk0p1 /dev/mmcblk0p1: Timing buffered disk reads: 66 MB in 3.07 seconds = 21.48 MB/sec

Not the fastest race horse but enough for what I have in mind.

Hello, you have to install the update downloaded from the manufacturer’s website for this device and then it will work, I also had the same problem, but I finally found out what to do and I did it and now it works normally

thank you, i will test here

Until today, testing several different distros, different sources etc, I still couldn’t get it to work, but it seems that the card starts, but it doesn’t have hdmi output, it’s not the Mini hdmi to hdmi adapter, it seems that it has something to do with the resolution, but even testing with different monitors still not successful.