Banana Pi does not boot past boot screen

My banana pi m2u does not boot past the boot screen.

It would start booting, I would see the logo and the boot output and when it is then supposed to display the desktop, it just turns off, the power and other LEDs turn off except the red LED at the WIFI and Bluetooth chip.

I have run Raspbien Jesse 2019 and 2020 and ubuntu mate server on it.

I have used 16GB sand-disk, microdigit, and SD cards and 32GB sand-disk and kioxia SD cards on it. The power adaptor is Oraimo 2A 5V output

I have changed SDcards (new ones) but it behaves the same. On one occasion, I removed the HDMI and all other peripherals and it booted fine but shut down the same way after about 10mins and kept behaving the same way.

1 Like

m2u or m2b? seems power supply issue

It is banana pi m2u

And when I checked at the official bpi m2u page, the input power specs is 5V 2A.

Besides, It worked very well at first

m2u power input is DC, not microUSB, if so and still shutdown or reboot, please upload the console debug message from power on to error or reboot time. (62.6 KB)

I have zipped the log files. You can get all the information needed from the log files

I have also seen this error:

GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Accounts was not provided by any .service files

I don’t know if it has anything to do with the problem. Despite that, it worked well at first.