Banana Pi BPI-M3 new image :Arch Linux sunxi kernel-4.18-rc3 and uboot- 2018.01 2018-07-19

I’ve prepared image for Banana Pi-M3 with Arch Linux sunxi kernel-4.18-rc3 and uboot-2018.01.

Maybe someone will find it usefull.

SMP - Works, Wifi - Works.

thank Andriy_Pankevych do this great work.

1 Like


1 Like

is it works with 7LCD module+touchscreen?

I don’t have LCD module to check but I’m afraid it won’t for now. I’ll investigate this and prepare new image.

Hey Andriy,

I’ve built myself the sunxi kernel but I’m having problems with NAT (iptables). Is your kernel working with iptables? If so can you share your .config for your compilation?

Also what is brcmfmac43430a0-sdio.txt, brcmfmac43430a0-sdio.bin and bcm43438a0.hcd? Bluetooth and wifi?


Hi Baskwo,

Have you enabled ip filtering in .config? It won’t work if proper option is not selected:

" Symbol: IP_NF_IPTABLES [=m] │
│ Type : tristate │
│ Prompt: IP tables support (required for filtering/masq/NAT) │
│ Location: │
│ -> Networking support (NET [=y]) │
│ -> Networking options │
│ -> Network packet filtering framework (Netfilter) (NETFILTER [=y]) │
│ -> IP: Netfilter Configuration "

brcmfmac43430a0-sdio.txt - broadcom wifi nvram, brcmfmac43430a0-sdio.bin - broadcom wifi firmware, bcm43438a0.hcd - bluetooth module.

You can try this config: .config (102.2 KB)

Yeah I figured out my problem, I was trying to add it as a module instead of in the kernel directly… I found my solution near 2am hahaha,

For the wifi firmware and bluetooth module do I have something to add in my kernel config?



For wireless:

Symbol: BRCMFMAC [=n] │
│ Type : tristate │
│ Prompt: Broadcom FullMAC WLAN driver │
│ Location: │
│ -> Device Drivers │
│ -> Network device support (NETDEVICES [=y]) │
│ -> Wireless LAN (WLAN [=y]) │
│ (1) -> Broadcom devices (WLAN_VENDOR_BROADCOM [=y]) │
│ Defined at drivers/net/wireless/broadcom/brcm80211/Kconfig:20 │
│ Depends on: NETDEVICES [=y] && WLAN [=y] && WLAN_VENDOR_BROADCOM [=y] && CFG80211 [=n] │
│ Selects: BRCMUTIL [=n]

shuold be enough. Also make sure you have firmware files in /lib/firmware/brcm/.

Enable bluetooth support in kernel for bluetooth and let me know if it works :). I havn’t tried yet.

Symbol: BT [=m] │
│ Type : tristate │
│ Prompt: Bluetooth subsystem support │
│ Location: │
│ -> Networking support (NET [=y]) │
│ Defined at net/bluetooth/Kconfig:5 │
│ Depends on: NET [=y] && !S390 && (RFKILL [=n] || !RFKILL [=n]) │
│ Selects: CRC16 [=y] && CRYPTO [=y] && CRYPTO_BLKCIPHER [=y] && CRYPTO_AES [=y] && CRYPTO_CMAC [=m] && CRYPTO_ECB [=m] && \ │
│ CRYPTO_SHA256 [=m] && CRYPTO_ECDH [=m]

Does not boot.

Burnt to SD card with Etcher and Win32DiskImager and just get the single red power light. No boot activity at all.

I find the lack of working software for this product disgraceful. I’ve only got one image to work properly, but that has kernel 3.6 which is not acceptable.

Definitely the worst product I’ve ever bought, and I can’t even eBay it because no one wants this piece of crap.

I’ve just re-tried:

/d/BPI> sudo dd if=./Archlinux-4.18rc3.img of=/dev/mmcblk0 bs=4M oflag=sync status=progress 7725907968 bytes (7,7 GB, 7,2 GiB) copied, 1104 s, 7,0 MB/s 1843+0 записів прочитано 1843+0 записів записано 7730102272 bytes (7,7 GB, 7,2 GiB) copied, 1104,64 s, 7,0 MB/s

Insert SD card and power on:

U-Boot SPL 2018.01 (Mar 24 2018 - 08:49:37) DRAM: 2048 MiB Trying to boot from MMC1 BPI: skip sunxi_mmc_getcd pin 166(0)

U-Boot 2018.01 (Mar 24 2018 - 08:49:37 +0200) Allwinner Technology

CPU: Allwinner A83T (SUN8I 1673) Model: Allwinner A83T BananaPi M3 Board v1.2 DRAM: 2 GiB MMC: SUNXI SD/MMC: 0, SUNXI SD/MMC: 1 In: serial Out: serial Err: serial Net: No ethernet found. starting USB… USB0: No host cable detected: Port not available. USB1: USB EHCI 1.00 scanning bus 0 for devices… 2 USB Device(s) found scanning usb for storage devices… 0 Storage Device(s) found Hit any key to stop autoboot: 0 BPI: skip sunxi_mmc_getcd pin 166(0) switch to partitions #0, OK mmc0 is current device Scanning mmc 0:1… Found U-Boot script /boot.scr reading /boot.scr 280 bytes read in 16 ms (16.6 KiB/s)

Executing script at 43100000

reading zImage 4050696 bytes read in 409 ms (9.4 MiB/s) reading dts/sun8i-a83t-bananapi-m3.dtb 21022 bytes read in 40 ms (512.7 KiB/s)

Flattened Device Tree blob at 49000000

Booting using the fdt blob at 0x49000000 Loading Device Tree to 49ff7000, end 49fff21d … OK

Starting kernel …

[ 0.000000] Booting Linux on physical CPU 0x0 … [ OK ] Started OpenSSH Daemon. [ OK ] Started Permit User Sessions. [ OK ] Started Serial Getty on ttyS0. [ OK ] Started Getty on tty1. [ OK ] Reached target Login Prompts. [ OK ] Reached target Multi-User System. [ OK ] Reached target Graphical Interface.

Arch Linux 4.18.0-rc3-455315-gb1df3f93ab46 (ttyS0)

alarm login:

Also ssh works out of the box:

/d/BPI> ssh [email protected] The authenticity of host ‘ (’ can’t be established. ECDSA key fingerprint is SHA256:x4mcGXdc4awLg+zqt4wHezTYThux/DYl4B3rDB/465g. Are you sure you want to continue connecting (yes/no)? yes Warning: Permanently added ‘’ (ECDSA) to the list of known hosts. [email protected]’s password: Last login: Wed Jul 18 06:50:34 2018 from [alarm@alarm ~]$

You need to know your IP. I use usb-ethernet.

New Image:

BananaPi-M3-Archlinux-4.18.1-1-ARCH Image for BananaPi-M3 Archlinux Kernel: 4.18.1-1-ARCH U-Boot: 2018.09-rc1

  • U-Boot: 2018.09-rc1
  • Kernel: 4.18.1-1-ARCH
  • Ethernet works
  • Wifi works
  • HDMI works
  • LCD needs to be checked(I would appreciate if someone can check it)
  • GPIO works(WiringPi)
  • BPI tools included
  • I2C enabled(In TDB file)

Clean CLI only. System is upgraded by 08.19.2018.

Direct download Image link:


Onboard leds do not work properly, solid red led is fine.

1 Like

I’ve created new topic: