Banana Pi BPI-M3 BTRFS and ZFS

Tried to use ZFS on M3, failed… Tried to use BTRFS, also failed. Checked /proc/filesystems, and looks like kernel doesn’t support none of them. Do you have any recommendations/ideas?

root@bpi-iot-ros:~# cat /proc/filesystems nodev sysfs nodev rootfs nodev bdev nodev proc nodev cgroup nodev cpuset nodev tmpfs nodev devtmpfs nodev binfmt_misc nodev debugfs nodev securityfs nodev sockfs nodev pipefs nodev anon_inodefs nodev rpc_pipefs nodev devpts ext3 ext2 ext4 squashfs nodev ramfs vfat msdos iso9660 nodev nfs nodev nfs4 nodev nfsd nodev cifs ntfs nodev autofs fuseblk nodev fuse nodev fusectl udf nodev ceph nodev functionfs

What OS and kernal have you installed? I also looked at me:

Hi Dmitri


Couple of places to look.

First are you mounting the XFS or BTRFS volume or booting from it ?

Looks like you are mounting.

Are you using the volume as a non privileged user ?

If you start from here New 4GB Image for BPI-M3

Add file systems by apt add fuse and auto mount.

This image will mount XFS and BTRFS

If building an image for EMMC the boot volume must be fat.