Banana Pi BPI-M2 Zero operating system

I took new M2 Zero for testing out of the box yesterday morning. HW looks good, but: So far I have not found any “official” operating system. I installed Raspbian, which is older than my whiskey. Tried Armbian, quite new but the image from Armbian web page is not installable. Just installed a version from some Google drive, which is not way I want to do if I want to make a real product with BPI. I need to know and trust what I install to the product. Experience with Armbian is not good. I installed desktop ok. Now if I open fex. settings window, the window just crashes and disappears after few minutes. Not usable at all.

Found deasent Ubuntu image.

Tried Android as the board is advertised to be compatible. The Android is version 4.4! What a joke! Newer I could not find.

What Linux version is installable as original version - if any?

Looks like a good hw has no real sw support - am I right?

I wish somebody with some better experience would like to reply. My route with BPI looks to end with disappointment.


I answer in another thread but I put the answer here for the records.

The “oficial” image is in fact for raspberry and dont have good support from BPI. In fact I contacted BPI directly because I cant make images works and they said me that the image (that I have downloaded from their google drive) wasn’t official.

In the M2Zero I have running correcly the Which is in the BPI-P2Z folder.

Still need to make a lot of work to get all software works, for example in the P2Zero the wiringPi library that is installed didn’t work, I need to uninstall and compile a modified version to make things work.

1 Like