Banana pi BPI-M2 Ultra/BPI-M2 Berry new image : 2017-05-25-raspbian-jessie-preview3-bpi-m2u-sd-emmc.img

  1. based on RASPBIAN JESSIE 2017-04-10 (support rpi3 rpi2 rpi1)
  2. support BPI-M2 Ultra & BPI-M2 Berry kernel 3.10.65
  3. username & password: pi/bananapi , root/bananapi
  4. support LCD 7"
  5. support LCD 5"
  6. support HDMI 1080P & 480P & 720P (default)
  7. support GMAC
  8. support WIFI
  9. support BT (with bluetoothctl can setup)
  10. support SATA
  11. support eMMC (support boot from eMMC, BPI-M2 Ultra only)
  12. support Battery (BPI-M2 Ultra only)
  13. support IR (getevent can test, BPI-M2 Ultra only)
  14. support touch screen (getevent to test) 14 support power key (getevent can test)
  15. support OTG & adbd (default off)
  16. support CAMERA ov5640 (guvcview / cap / ffmpeg-3.2.1 support video H.264 hw encode)
  17. support uEnv.txt to fatload uImage
  18. support bpi-bootsel to set LCD7" / LCD5" / HDMI (720P & 1080P & 480P)
  19. support bpi-copy to write SD/eMMC with file
  20. support video play 1080p with vdpau (vlc)
  21. support wiringpi 2.44 (, thanks to &
  22. support rpi.gpio 0.6.3 for python (, thanks to
  23. Thanks for linux-sunxi community (
  24. Special thanks for Alex support with camera functions (
  25. thanks for’s work(
  26. support node-red with raspberrypi’s node to control gpio

Google Drive:

baidu cloud:

MD5: 60e19ea9138d6841fa6852ece4727b0a

FILESIZE: 1946658225(~1856MB) UNPACK: 7456MB (eMMC size)

support Node-RED

test OV5640 camera module

test 5`0 touch screen

test 7`0 touch screen

1 Like

Hello @sinovoip

I have installed this image and it is working but I have 2 questions:

  1. why are you using such an old kernel - 3.10.65? Will kernel be updated in your next img?

  2. I have an issue with sunxi-bt. It is logging to syslog every 5 seconds “sunxi-bt bt: block state already is 0”. Can you confirm this is an issue with the img? Any idea how to resolve it?

thank you.

OK Thanks. I’m really not sure what to do with this board now. I think the only option for me (very limited skills!) is to wait for a better and more robust image.

Are there any other debian images that I can try or do i need to wait for another release here?

Thanks for the info. Silly to purchase this M2U without proper research first. On the positive, i have it running as a NAS. It’s been running for the last 5 days without too many issues. Just want to get rid of the 17,280 sunxi-bt error messages that are being logged every day!

haha. I hope so. I have googled this issue and I can’t find anything helpful.

I can’t even work out how to disable BT and/or wifi at the CLI. I’m not using either so happy to disable to see if this will clear the issue.

Thanks for answering my posts. I don’t feel so lonely on this forum any more.

@sinovoip This version of debian also has stability issue. It often reboots occasionally.

Most probably this is not related to debian but maybe memory is overclocked:

You might ask these guys how to fix this (since @sinovoip ignores user requests, questions and the need for support): BPI-M2U UART on gpio pins

@charles Thanks for your information. I change frequency of memory to 576MHz in sys_config.fex, managed to compile the kernel and update my m2u with that kernel. I will see if the instability issue is solved. If solved, I will write a detailed post.

any update? now ur pi running smooth? if then can you share the files?


Yes, My m2u has ran for 7 days. I should have written a post, but I was easy on workdays. I will write one at weekend.

You can pull my fork and see what I have modified. facat/BPI-M2U-bsp

thank you for you hard work to support our project .

can u provide me any tutorial link from where i can learn how to fork and use your modified bsp?


You may see this an-unofficial-method-to-solve-instability-problem

lol,good luck with that… i’m still waiting for good images for m2.

I have got my m2u working quite well now thanks to a number of people on this community. In summary:

  1. use the latest debian image available from download page (may 2017)
  2. follow instructions above to update kernel and u-boot etc

You end up with debian kernel 3.10.107 and it seems to be stable so far.

1 Like

is there any way to add the module dvb_usb_v2 to this image

I am newbie, trying to install qt4 dev. tools on bananapi. During installation half of the way, i for this error message: “dpkg was interrupted, you must manually run 'sudo dpkg --configure -a’to correct the problem.” I tried this too then i get the error: [dpkg: error: failed to open package info file /var/lib/dpkg/updates/0049 for reading: Input/output error]

Tried to remove the ‘0049’ from the updates, but couldn’t.

uname -a give me this; Linux bpi-iot-ros-ai 3.10.65-BPI-M2U-Kernel #1 SMP Thu May 25 11:46:04 CST 2017 armv7l GNU/Linux

please help. thanks in advance.