Armbian on BPI-M64: Reliably start network on boot


I have a USB Wi-Fi adapter in my BPI-M64, which is running the current latest Armbian image from the official download location. Armbian does find the network adapter and configure it, but it does not always automatically configure on boot. Sometimes it suffices to explicitly run dhclient wlan0, sometimes I have to reboot. Other times, the network is working fine after a boot. I have the following command in /etc/wpa_supplicant-start:

wpa_supplicant -B -D nl80211 -i wlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf

Scanning /etc for references, I also see this line in /etc/network/interfaces.d/wlan0:

wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

I think the configuration is essentially correct, based on the fact that about half of the boots, the network comes up entirely properly of its own accord, but I don’t know why it doesn’t start reliably or how to fix it.

Anybody know?



If you are using Armbian, just follow their documentation and it will work the way you expect.

Their documentation says to use a TUI tool armbian-config. It also explicitly says:

Note: armbian-config is undergoing major rewrite and therefore is not receiving much attention. So functions might not be available or even broken, especially on more recent boards.

It does not indicate what exactly armbian-config is setting behind the scenes.

Negative. This is what the docs says:

As this tool (nmtui-connect) (not designed by Armbian but RedHat corporation) is only a wrapper, the problem could be elsewhere.

That documentation states:

Required condition: a board with onboard or supported 3rd party wireless adapter on USB

But it doesn’t provide any indication of what 3rd-party adapters are supported. It also indicates how to connect to a given network in the moment, but it doesn’t indicate how to configure it to do so automatically on boot.

So you will invest few weeks and invest few thousands into that research and share it with us.

Connection is established on boot automatically if done this way. If not, there could be a problem in driver …