Armbian_5.41 Upgrade Crashes


I installed the image Armbian_5.41_Bananapim64_Ubuntu_xenial_next_4.14.18_desktop.img on eMMC. Then I updated the OS via: apt-get update & upgrade. The device then booted and got stuck at Armbian logo with the following error message at the bottom of the screen:

"Unable to handle kernel paging request at virtual address fff00000fff00"

Is this a bug or what? Thanks in advance.

Armbian sponsor expensive manual test upgrades only on supported boards. Hard to say, what went wrong, but latest clean images should work.

The image Armbian_5.41_Bananapim64_Ubuntu_xenial_next_4.14.18 does work. The problem is after running apt-get update & upgrade. Maybe my bpi m64 has a RAM memory issue? Is there a way to check it? Thanks.

Official Armbian images are v5.69 and come with a kernel 4.19.13

I just downloaded Armbian_5.69_Bananapim64_Debian_stretch_next_4.19.13.img from the link you provided and burned on a SD. My BPI M64 freezes while loading the OS on the Armbian Logo. I tried with different SD cards and the same issue happened. I also tried with Armbian Bionic but the system freezes as well.

The images Armbian_5.41_Bananapim64_Ubuntu_xenial_next_4.14.18_desktop.img and Armbian_5.41_Bananapim64_Debian_stretch_next_4.14.18_desktop.img works fine. The problem is when I upgrade the system. I believe this is a bug.

I test the exact image - can’t reproduce. At least not with my Banana and my pitch perfect lab cabling/PSU. and after update

Start here to rule out basic problems. It can be more sinister like your memory is border quality. Diagnostic such problems is hard if you are alone and if you only have one board … which works.

Thanks for your support but nothings seems to work for me. Below is what I did and whats going on:

  1. BPI M64, SD Card class 10, PSU 5V 2A
  2. Armbian_5.41_Bananapim64_Ubuntu_xenial_next_4.14.18_desktop.img works fine 3.Armbian_5.69_Bananapim64_Ubuntu_bionic_next_4.19.13_desktop.img does not work. It freezes when loading the system no matter if burned on eMMC or SDcard.

OBS: I erased eMMC with /dev/zero. I tried with armbian-config in order to burn the image to eMMC and also doing dd from CLI. Both methods did not work.

Unfortunately I will most probably have to wait for a newer version of this great OS.

Just to update this thread. I installed Armbian 5.65 Ubuntu bionic 18.04 kernel 4.14.78-sunix 64. Everything works fine if I do not update the following kernel related packages:

linux-dtb-next-sunix64 linux-image-next-sunix64

If I update the above mentioned packages then the system does not boot and freezes on the Armbian logo.

Those packages (except netplan) are a kernel image and device tree blob (hw settings for this kernel) which doesn’t seem to like your board.

Confirm this issue (i.e. unable to install debian buster due kernel crash occured). Issue located at linux-dtb-next-sunix64 package. Temporary solution:

  • install debian stretch;
  • hold working package and update stretch to last release by following commands: apt-mark hold linux-dtb-next-sunxi64 apt-get update apt-get --autoremove dist-upgrade
  • reboot computer
  • edit files /etc/apt/sources.list and /etc/apt/sources.list.d/armbian.list (replace all “stretch” to “buster”)
  • perform standard upgrade procedure by following commands: apt-get update apt-get --autoremove dist-upgrade