Arduino1.5.4 running Arduino Due

Shared by Surapol

I connected Arduino Due and set serial port and board correctly and tried to compile Blink program in the Example folder. The complier finish the compiling with error said "Cannot run program /opt/arduino-1.5.4/hardware/tools/g++_arm_none_eabi/bin/arm-none-eabi-g++ no such file or directory. I checked and confirm missing file in the directory. Please help me to get the file in order to make the Arduino Due work properly. Thank you.

I managed to make everything work after a long compile (8 hours) as followings.

sudo apt-get install curl flex bison libgmp3-dev libmpfr-dev texinfo libelf-dev autoconf build-essential libncurses5-dev libmpc-dev 

git clone [url][/url]
cd arm-eabi-toolchain
make clean
sudo make install-cross

After 8 hours, the build produced the directory /home/pi/arm-cs-tools which I will link missing file to here as followings.

sudo mkdir /usr/share/arduino/hardware/tools/g++_arm_none_eabi
sudo mkdir /usr/share/arduino/hardware/tools/g++_arm_none_eabi/bin
cd /usr/share/arduino/hardware/tools/g++_arm_none_eabi/bin
sudo ln -s /home/pi/arm-cs-tools/bin/arm-none-eabi-ar arm-none-eabi-ar
sudo ln -s /home/pi/arm-cs-tools/bin/arm-none-eabi-g++ arm-none-eabi-g++
sudo ln -s /home/pi/arm-cs-tools/bin/arm-none-eabi-gcc arm-none-eabi-gcc
sudo ln -s /home/pi/arm-cs-tools/bin/arm-none-eabi-objcopy arm-none-eabi-objcopy
sudo ln -s /home/pi/arm-cs-tools/bin/arm-none-eabi-size arm-none-eabi-size

Now compile work but upload to Arduino Due fail. Solved as followings.

git clone
make strip-bossac

Then copy bossac to /usr/share/arduino/hardware/tools/ Now everythings works. OK