Arch linux on Bpi M2 ultra?

Is there arch linux image that could run on Bpi M2 ultra with support for emmc boot?

we will support arch linux image later .

arch linux update :

Hi sinovoip, I successfully installed the archlinuxarm image on my banana pi m2u. It appears to not use the installed linux-armv7 kernel (4.17.6-1), but a rather old kernel instead (3.10.107-BPI-M2U-Kernel). The problem is now, that some basic tools do not work, e.g. “dig” gives me this error:

$ dig random.c:102: fatal error: RUNTIME_CHECK(ret >= 0) failed Aborted (core dumped)

Any idea how I can make it use the archlinuxarm kernel? (I tried entering it in my uEnv.txt already, but it refuses to boot - most probably, because I didn’t know how to specify the ramdisk) Cheers, deep42thought

Anyone got an Arch Linux with kernel 4 ?

@stevel: you are aware of the Arch Wiki entry? (which I was unsuccessful to get running on my Banana Pi 2 Berry so far)

I was able to make Arch img for r2 which is armv7h, I dont have M2 to work on it. But If you need I can make a generic image where you can add the kernel and dtb yourself.

I went with a different approach: first I installed the Arch image from BPI-M2 Ultra/BPI-M2 Berry new image:2017-8-28 kali linux,crux linux,archlinux,centos linux image. It’s a Version 3 kernel, so I then attempted to upgrade it, first by mounting the SD card root partition on /mnt, then the boot partition on /mnt/boot, then arch-chroot /mnt, then pacman -Syu.

Unfortunately that didn’t work - although the boot partition now has a new initramfs-linux.img and zImage, I’m assuming I have a boot method mismatch because the old kernel version is always booted.

I’m not familiar enough with the Arch boot process to understand what is going on, so any suggestions will be gratefully accepted.

@spikerguy: yes, that would be great! @stevel: I’m running my banana pi this way for one or two years now (new arch packages, old kernel) - but two weeks ago or so, ssh broke (client and server) and I strongly suspect, that there is some cipher it tries to use nowadays which the kernel does not support. I also tried updating the kernel more forcefully by replacing the provided kernel and initramdisk (the kernel and initramdisk that is being used is buried beneath some layers of subdirectories in /boot), but had no luck this way …

I think I know what is going on, and it is the root cause of my problem too: the latest ssh enforces privilege separation but the old kernel doesn’t support it.

This will break the boot process.

This is because of the uboot, as uboot always look for uImage in the boot partition.

Thanks @spikerguy - that confirms it is a boot issue not an upgrade issue per se. I’ll continue reading on how to a convert to uImage with the goal of booting Arch out of the eMMC, using either kernel 4 or 5.

You will have to compile kernel for this device from the source. Please check who is maintaining the kernel for m2 ultra. Maybe he have the compiled kernel which he can share with you so you don’t have to do much just replace those files and it should boot.

I was just able to build archlinux img for R2 which is also armv7, so you can use my rootfs but will need uImage from the kernel. I will check with bpi repo and their team but they’re only holiday now.

How would I check who is maintaining the kernel for the m2 ultra? My web searches have drawn a blank.

Also, I followed the instructions on how to alter Uboot, Kernel at but the first link to 404s.