AP Mode Doesn't Work

Dear Support,

We tried to use Banana Pi BPI M3 A83T device to be an Access Point. After we completed to set up this device to AP mode, we use mobile phone to detect SSID nearby but cannot found it.

Below is Banana Pi BPI M3 version information:

  • OS: Rasbian 9 (Stretch)
  • image: 2021-08-03-raspbian-stretch-bpi-m3-sd-emmc.img.zip

The attached file shows the startup message of hostapd Server and the settings of AP mode: Linux_AP_Mode_en.pdf (273.8 KB)

Please help us to review the AP mode information we set up and to see if there is any wrong setting or other settings we missed and needed to set up.

Best Regards, David Huang

try this https://www.armbian.com/bananapi-m3/

Hi igorpec,

Thanks for your information. The link information we tried but still cannot solve our problem.

The issue phenomenon:

  • Armbian_22.11.0-trunk_Bananapim3_bullseye_edge_6.0.9.img: This image doesn’t provide desktop UI operations.
  • Armbian_23.02.0-trunk_Bananapim3_kinetic_edge_6.0.12_xfce_desktop.img: This image cannot boot to desktop. It hangs up on black screen.
  • Armbian_23.02.0-trunk_Bananapim3_sid_edge_6.0.12_xfce_desktop.img: This image is not stable. It’s hard to boot to desktop. It is very easy restart when tring to burn the image to EMMC.

So the above three images still cannot work to meet our project needs.

Is there any newer or stable version (image) with desktop UI that we can try?

Best Regards, David Huang

Not that I am aware. You do understand that this hardware is running open source software?