1st steps with BPi-M3

I tried all 4 available OS images from the download page but to no avail. When flashing Android to eMMC I get a system with one active CPU core and where I can’t do anything useful (I want to test an SBC and don’t fiddle around with an Android toy).

All 3 Linux images are corrupted according to “unzip” (I extracted the images using TheUnarchiver that didn’t complain) and since SinoVoip doesn’t provide at least MD5/SHA1 checksums to check download integrity I’m a bit stuck now.

Boot logs made using serial console can be found here: http://linux-sunxi.org/User_talk:Tkaiser#First_steps_with_Banana_Pi_M3

Both Ubuntu and Debian fail with

EXT4-fs (mmcblk0p2): bad geometry: block count 1854464 exceeds size of device (1849344 blocks)
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(179,2)

And Raspbian finds a rootfs but fails a bit later:

VFS: Mounted root (ext4 filesystem) on device 179:2
Unable to handle kernel paging request at virtual address 0000b950

@sinovoip: when will you provide an OS image containing the latest hardware initialisation fixes from Github, that is known to work and with MD5/SHA1 checksum to verify download integrity?

I’m in: http://pastebin.com/xEduFFDR

Just combined the skeleton of the Raspbian image with the freshly built BSP stuff with a known working rootfs (in my case loboris’ Ubuntu Vivid image for Orange Pi PC)

root@OrangePI:~# uname -a
Linux OrangePI 3.4.39-BPI-M3-Kernel #2 SMP PREEMPT Mon Nov 30 15:10:54 CET 2015 armv7l armv7l armv7l GNU/Linux
root@OrangePI:~# cat /proc/cpuinfo 
Processor       : ARMv7 Processor rev 5 (v7l)
processor       : 0
BogoMIPS        : 4800.00

processor       : 1
BogoMIPS        : 4800.00

processor       : 2
BogoMIPS        : 4800.00

processor       : 3
BogoMIPS        : 4800.00

processor       : 4
BogoMIPS        : 4800.00

processor       : 5
BogoMIPS        : 4800.00

processor       : 6
BogoMIPS        : 4800.00

processor       : 7
BogoMIPS        : 4800.00

Features        : swp half thumb fastmult vfp edsp thumbee neon vfpv3 tls vfpv4 idiva idivt 
CPU implementer : 0x41
CPU architecture: 7
CPU variant     : 0x0
CPU part        : 0xc07
CPU revision    : 5

Hardware        : sun8i
Revision        : 0000
Serial          : 402000f08100a5075604
root@OrangePI:~# cat /proc/meminfo 
MemTotal:        2061116 kB
MemFree:         1843552 kB
Buffers:           14056 kB
Cached:            99368 kB
SwapCached:            0 kB
Active:            69040 kB
Inactive:          87780 kB
Active(anon):      44880 kB
Inactive(anon):    11688 kB
Active(file):      24160 kB
Inactive(file):    76092 kB
Unevictable:           0 kB
Mlocked:               0 kB
HighTotal:       1458176 kB
HighFree:        1286496 kB
LowTotal:         602940 kB
LowFree:          557056 kB
SwapTotal:             0 kB
SwapFree:              0 kB
Dirty:                36 kB
Writeback:             0 kB
AnonPages:         43416 kB
Mapped:            30052 kB
Shmem:             13172 kB
Slab:              24328 kB
SReclaimable:      10856 kB
SUnreclaim:        13472 kB
KernelStack:        1224 kB
PageTables:         1592 kB
NFS_Unstable:          0 kB
Bounce:                0 kB
WritebackTmp:          0 kB
CommitLimit:     1030556 kB
Committed_AS:     349428 kB
VmallocTotal:     385024 kB
VmallocUsed:       40268 kB
VmallocChunk:     212736 kB

Seems I’ve been wrong in many regards. The A83T is really fast and with an applied heatsink climbs up to 1.6 GHz (and with improved cooling it should be possible to reach even higher clockspeeds without any overvolting/overclocking, just by preventing thermal throttling from jumping in).

Just a first small impression using

  • sysbench --test=cpu --cpu-max-prime=20000 run --num-threads=8
  • 7za b
  • mbw -t0 256 && mbw -t1 256 && mbw -t2 256

for small integer and memory performance measurements: sysbench 66.9 seconds, 7-zip score 5014, memory bandwidth: 501.7, 448.4, 518.4 MiB/s

That’s not only twice as fast as the few quad-core SoCs I’ve tested, the A83T remained ‘cool’ due to throttling at approx. 75-80°C so there’s a lot of room for improvement. As a reference a few other SoCs I ran the same benchmarks on: http://forum.armbian.com/index.php/topic/311-quick-review-of-lemakers-guitar/

Another update. SinoVoip fixed just today LED functions: https://github.com/BPI-SINOVOIP/BPI-M3-bsp/commits/master but other issues still persist, eg. https://github.com/BPI-SINOVOIP/BPI-M3-bsp/issues/3

USB-to-SATA throughput depends on cpufreq settings (13/23 MB/s @ 480 MHz vs 15/30 MB/s @1800 MHz write/read – even the last value is really bad compared to good USB-to-SATA implementations) and the thermal stuff is quite interesting. Without active cooling you’re far away from being able to run the A83T above 1.2/1.6 GHz over a minute. But with a good heatsink applied the A83T is able to perform really fast over short periods of time (until throttling jumps in and reduces cpufreq or drops cores)

Since still only broken OS images are available here http://www.banana-pi.org/download.html and according to the commit log above they started just recently to fix basic stuff like wrong DRAM initialisation, LEDs, BT and so on I would suspect we’ve to a wait a few weeks until software left alpha state.

we have test ubuntu 15.10 image , will update soon.

I had a 15.04 image and updated right now:

root@BPiM3:~# cat /etc/lsb-release 

root@BPiM3:~# apt-get install update-manager-core && do-release-upgrade

root@BPiM3:~# cat /etc/lsb-release 

Quite unimpressive. The magic happens somewhere else: bootloader, kernel and hardware initialisation. And there we have to rely on you: https://github.com/BPI-SINOVOIP/BPI-M3-bsp/commits/master (these fixes are important not the result of a ‘do-release-upgrade’ call)

Well, you got your image working, @lionwang updated github so that the LED is blinking. What else do you need - it is blinking and runs. This is a developer-board, not for production.

If the intention is production, then in the last couple weeks before release you would have seen commits on github.