BPI-M2 Ultra/BPI-M2 Berry new image : Armbian Bionic and Stretch


(Igor) #41

HDMI seems to be broken when switching u-boot to 2018.11


#42

Hi!

I am newbie with Bpi M2U, the 5.69 armbian not booting, but 5.71 boot, and I can not turn on the spidev. I used the armbian-config. Any suggestion?

Thank you in advance for your answers.


(Igor) #43

Overlays for R40 are not developed so you can’t just turn them on. You have to fiddle manually with board DTB. No idea if SPI works.


(Mario Frost) #44

Hello, unfortunately i have no skills in programming and also my kowledge might be not huge enough to exactly understand why i have the problem with i2c, so i hope it is okay to ask here.

I tried to activate the I2C in armbian-config to get an oled, bmp sensor and others working. But i2cdetec will detect none of them - so i guess the activation don’t really work!? I also tried to figure it out with several toturials from the internet, where other were able to use i2c with a bananapi. Is my failure image related (maybe not implemented functions?) or am i the layer 8 problem and i’m ‘not to see the wood for the trees’?


(Igor) #45

It is perfectly O.K. if you don’t have the knowledge and if you asks. And I already gave you the answer. There is no support for manipulating HW functions on R40 in a simple manner. Why? Because nobody developed that. I am not 100% sure, but I think functions are supported by the kernel, but their manipulation is not brought up to the human readable levels. And there is no certainty this will ever be. Our resources are 100x too small to fix all those things …


#46

Don’t mix up a bananapi from “Hard Kernel” and a banana-pi from SinoVoIp !

If it’s just for playing with a BMP sensor and an OLed display, it’s better to use a ESP8266 with LUA language and Wifi for saving big datas on the cloud. It’s working fine and cheaper.


(Mario Frost) #47

Thanks for the answers. My intention was to bring my home-automation (FHEM and Nextcloud) into my 19" rack. For this adventure i chose this way: https://www.thingiverse.com/thing:2894571 My decision / choice was to use a BananaPi M2 BRY instead of a RaspberryPi 3B+, because i wanted to use the SATA port of the M2 BRY and take the read/write load from the SD card. For the RaspberryPi it’s very simple to active the I2C and connect the oled to show the parameters to monitor. All i wanted to do was to do the same on the M2 BRY, but it wasn’t clear to me that there is a problem with this. Are there other ways to realize this part of the project? regards Mario


(Igor) #48

For that you have boards with eMMC and have system there … which is closer to SSD than SD card.

Virtually on any other board (Allwinner A10, A20, H3, H5, A64, Rockchip RK3288, Amlogic, …) activating I2C would be simple in armbian-config

In term of money - buy appropriate board and forget about SATA function. Implementation is slow. Use some H3/H5 board (which are very well supported) and USB2SATA bridge https://forum.armbian.com/topic/1440-h3-devices-as-nas/

or find someone to implement this on R40.


#49

If you have a lot of datas that requires a SATA port, you can use a bananapi pro

https://www.armbian.com/banana-pi-pro/

Otherwise, you can use an orangepi-pc-plus with 8Go Emmc


(Tomas) #50

Hello, I have the same issue. Do you have any solution now ? I have problem with i2c3 only. I2cdetect command is very slow and with bad result.

Thank you Tomas


(Jason) #51

I can see Armbian build for the board keep updated and it’s now with 5.1.0 kernel, thanks for the effort, so exciting!

Is DVFS still not working? The board seems to be slightly hot after booting when it doesn’t have any extra tasks to run. Does Armbian have anywhere to track issues for this project?

Thanks, J