BPI-M2 Ultra/BPI-M2 Berry new image : Armbian Bionic and Stretch


(Nik) #21

I have the same issue with i2c. i2c configuration in dtb/dts is “okay”:

            i2c@1c2b000 {
                    compatible = "allwinner,sun6i-a31-i2c";
                    reg = <0x1c2b000 0x400>;
                    interrupts = <0x0 0x8 0x4>;
                    clocks = <0x4 0x58>;
                    resets = <0x4 0x41>;
                    status = "okay";
                    #address-cells = <0x1>;
                    #size-cells = <0x0>;
                    phandle = <0x59>;
            };

            i2c@1c2b400 {
                    compatible = "allwinner,sun6i-a31-i2c";
                    reg = <0x1c2b400 0x400>;
                    interrupts = <0x0 0x9 0x4>;
                    clocks = <0x4 0x59>;
                    resets = <0x4 0x42>;
                    status = "okay";
                    #address-cells = <0x1>;
                    #size-cells = <0x0>;
                    phandle = <0x5a>;
            };

            i2c@1c2b800 {
                    compatible = "allwinner,sun6i-a31-i2c";
                    reg = <0x1c2b800 0x400>;
                    interrupts = <0x0 0x58 0x4>;
                    clocks = <0x4 0x5a>;
                    resets = <0x4 0x43>;
                    status = "okay";
                    #address-cells = <0x1>;
                    #size-cells = <0x0>;
                    phandle = <0x5b>;
            };

            i2c@1c2c000 {
                    compatible = "allwinner,sun6i-a31-i2c";
                    reg = <0x1c2c000 0x400>;
                    interrupts = <0x0 0x59 0x4>;
                    clocks = <0x4 0x5f>;
                    resets = <0x4 0x48>;
                    status = "okay";
                    #address-cells = <0x1>;
                    #size-cells = <0x0>;
                    phandle = <0x5c>;
            };

After reboot there are 6 i2c devices:

root@bananapim2ultra:/dev# ls /dev | grep i2c
i2c-0
i2c-1
i2c-2
i2c-3
i2c-4
i2c-5

i2cdetect -y 0 works too slow… And finally there are no avaliable i2c devices. I use DS3231 clock, it works correctly with [orange pi pc + / Armbian].

Any idea?.. Thanks in advance.


#22

My LED solution is:

nano /etc/tmpfiles.d/leds.conf

w /sys/devices/platform/leds/leds/bananapi:red:user/trigger - - - - default-on w /sys/devices/platform/leds/leds/bananapi:green:user/trigger - - - - heartbeat w /sys/devices/platform/leds/leds/bananapi:blue:user/trigger - - - - mmc0

I use BPI-M2U and Armbian Stretch.


#23

@ayarovy,

My BPI is powered by “ARMBIAN 5.59.180823 testing Ubuntu 18.04.1 LTS 4.18.13-sunxi” I had the following line in /etc/rc.local file for blinking the green led on board :

echo heartbeat > /sys/class/leds/bananapi:green:user/trigger

But I wish to display IP-address and free disk-space on an OLed 0.96". My BPI is headless and acts as a NAS.


(Mike) #24

I’m trying Armbian_5.59.180823_Bananapim2ultra_Debian_stretch_dev_4.18.4.7z or Armbian_5.59.180823_Bananapim2ultra_Debian_stretch_dev_4.18.4.7z on Banana Pi M2 Berry and fail miserably. What I did:

  • download the 7z files, unpacked (Win10)
  • verified the checksum of the unpacked .img files
  • wrote the image file to a single-partition 16GB SD-card using Win32 Disk Imager and Etcher => in contrast to other tried distributions the SD-card remains single-partitioned (the other Linux distributions created 2 partitions, one DOS partition and another one unreadable on Windows)
  • stick the SD-card into the BPiM2Berry => the red LED is on, but that’s it - no green LED, no HDMI output, no network access

(Mike) #25

I tried again (with dis-/reconnecting the monitor) and eventually noticed that it reacted to the Banana Pi’s power button. The screen did not turn into standby mode and by luck I’ve noticed a flashing _ at the left top corner. After waiting a while it showed the usual login.

So for all users who try:

  • there really is just one partition on the SD card
  • the green LED does not indicates any operation
  • there is no boot message output on the HDMI

(Igor) #26

Updated images and enabling verbose booting on HDMI screen.