Banana Pi BPI-R2 new image : Official OpenWRT 18.06.0


(Maciek Szelągowski) #1

OpenWRT 18.06 released and I can see image for BPI R2

safe_image

https://downloads.openwrt.org/releases/18.06.0/targets/mediatek/mt7623/

seems it’s official


(Try Infinity) #2

Can you add some details about what this version can do and what does it support? Also, how can I build the files on openwrt.org? Thank you


(Maciek Szelągowski) #3

sorry, I did not compile this version. It’s just compiled by OpenWRT team.

I only found this information on some website …


(Frank W.) #4

Official from openwrt-team but not bananapi/sinovoip so you should look/ask in openwrt-documentation


(Ramon Smit) #5

It looks indeed like a official build from the OpenWRT team. It’s nice to see that OpenWRT is going to support the R2. This might be a future for stable kernels?


(Frank W.) #6

Imho openwrt only supports thing from mainline (soc-support and basic board-support).other things like wifi-driver second gmac or others are possibly not supported. There are patches for it,but these have to manually applied


(Maciek Szelągowski) #7

Anyone now how to put those .bin file to SD?


(Frank W.) #8

Have you tried simple

sudo dd if=7623n-bananapi-bpi-r2-initramfs-kernel.bin of=/dev/sdx

?


(Maciek Szelągowski) #9

sure, but doesn’t boot. Will try to attach log


#10

It doesn’t sound like it will be officially supported any time soon judging from this https://github.com/openwrt/openwrt/pull/1135


(Maciek Szelągowski) #11

That’s true. Due to lack of support from Sinovoip I bet none of OpenWRT / Armbian will ever be supported. I have banana pi pro (Leemaker) and it’s fully supported. What a pity …


#12

I load oficial image via tftpboot in uboot:

setenv ipaddr 192.168.2.150 
setenv netmask 255.255.255.0
setenv serverip 192.168.2.2
tftpboot openwrt-18.06.1-mediatek-mt7623-7623n-bananapi-bpi-r2-initramfs-kernel.bin
bootm

But image have a limitation:

root@OpenWrt:/# opkg install nano
Installing nano (2.9.8-1) to root...
Collected errors:
 * verify_pkg_installable: Only have 0kb available on filesystem /overlay, pkg nano needs 63
 * opkg_install_cmd: Cannot install package nano.
root@OpenWrt:/# mount
rootfs on / type rootfs (rw)
proc on /proc type proc (rw,nosuid,nodev,noexec,noatime)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,noatime)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,noatime)
tmpfs on /dev type tmpfs (rw,nosuid,relatime,size=512k,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,mode=600,ptmxmode=000)
debugfs on /sys/kernel/debug type debugfs (rw,noatime)
root@OpenWrt:/# df -h
Filesystem                Size      Used Available Use% Mounted on
tmpfs                   504.2M    648.0K    503.6M   0% /tmp
tmpfs                   512.0K         0    512.0K   0% /dev

fdisk, block-mount and kmod-fs-ext4 are missing


(Robert) #13

Awesome! I built the source and am trying to get it to boot currently


(Frank W.) #14

Seems that rootfs is readonly…only some other directories like var/sys are mounted over it as tmpfs (ramdrive) to get write-access. I don’t know how to write to type rootfs…i guess it is a buildtin initramfs which needs to be unpacked,packed and recompiled into kernel


(Maikeul K) #15

Hi, I’ve Tried Command : sudo dd if=7623n-bananapi-bpi-r2-initramfs-kernel.bin of=/dev/sdx

But doesn’t work. Any solutions? Thanks


#16

I don’t know why this device say that have compatibility with OpenWRT. Everything are problems.

I have my own build, without problems, but I don’t have instructions of how to put the images in the device. Try and error, but without results.

Please, somebody know how to put the images of build of OpenWRT 18.06.1 in the device?

Thanks in advance.


(Robert) #17

You can use U-boot, here are some simple instructions.

  1. install a tftp server on a ubuntu machine or VM and move your initramfs-kernel.bin to the tftp folder
  2. flash the latest version of ubuntu fo the R2 onto an sd card
  3. during boot select the uboot console option
  4. enter the following commands:
     setenv ipaddr 192.168.2.150 // replace with a local ip address on your network 
     setenv netmask 255.255.255.0
     setenv serverip 192.168.2.2 // replace with the ip adress of your machine with the tftp server
     tftpboot openwrt-18.06.1-mediatek-mt7623-7623n-bananapi-bpi-r2-initramfs-kernel.bin // replace with the name of your image
     bootm 
    
    

Openwrt will now boot, I am working on a script for u-boot to handle all this stuff automatically


#18

That’s is ok. I know the method. But, how can I put the system in the EMMc or SD and install luci and other tools… how can I do the sysupgrade?

do I need to boot always from tftp?

Thanks


#19

You can instalar some things if you create a /overlay over tmpfs

mount -t tmpfs -o size=512m tmpfs /overlay

opkg update

opkg install blkid lsblk e2fsprogs kmod_fs_ext4 openssh-sftp-server …

But…, how can I manage the emmc or sd?

Obviously, if you reboot, you lose all.


(Robert) #20

I can create a partially bootable image by writing the initramfs-kernel.bin to the bpi-root of the latest Ubuntu image but it hits a kernel panic