OpenWRT @ BPI-R2 EMMC - What am I doing wrong?


I’ve got a BPI-R2 into which I’ve been trying to install OpenWRT.

I’ve seen there are two forks besides the main branch:

  • Master OpenWRT 18.06 (now 19.06)
  • Lexa2 build

I have tried every single document I’ve found in order to install any of the three builds with the compiled drivers I need.

I have succeded building the Kernels and the EMMC/SD images (either manually or with the automatic image building of the make) but every time I get the same kind of error: Either the kernel loads but wont have persistent fs or there will be “Could not find kernel image (Mostly when using emmc blocks)”

In any case, I have never succeeded on making the system mount the right partitions so the system is always non-persistent. The only way I’ve managed to boot OpenWRT is by creating the vfat/ext4 partitions.

I have tried all the different uboot versions there are out there and now I’m wondering if I should compile my own uboot as well?

I keep getting errors such as:

I’ve noticed that the uboot points to rootfs=ext4 and root mountpoint /dev/mmcblk0p2 so I intalled it that way --> same issue-

I’ve tried using SPFlash and building my own Scatter file to define the blocks where to flash (to workaround the bad CRC, no image found) issue when ussing MMC.

So far I’ve been unsuccesful and I’m about to throw the board in the trash and move on to other things.

I’ve noticed that there are different entry points for the kernel and different MBR’s.

Can anyone please (Im begging) help me figure this out? I have kernels compiled with the drivers I need and rootfs/ext tar.gz files for the different builds but I’m just uunable to flash it properly

any help will be appreciated.

This is the log to one of the error boots: Note that the bootargs point to a partition ext4 but when I execute “printenv bootargs” it shows a different parametre (with the mtd blocks).

I’ve wasted all my christmas holidays (From the 22th to the 7th (and beyond)) with this so my desperation level is overwhelingly high…

Thanks in advance,

I am in the same case. The board has 1 year now. I don’t know why they say that they have openwrt support. I don’t know why is the bin files in the OpenWrt repository…

Last try, 19.07.1. All possible combinations. Nothing.

The black aluminium case is very beautifil!!!