Banana PI BPI-M64 New Images :Ubuntu16.04 & Android 6.0 Release 2018-09-18


(ZB) #1

BPI-M64 New Image Ubuntu16.04 & Android 6 Release 2018-09-18

image

1.About this release

  • This release is for banana pi M64 board which is based on Allwinner A64, We release three Images, Ubuntu 16.04 Desktop & Android is based on kernel 3.10.

2.M64 Ubuntu 16.04 Desktop

  1. Features Map
  1. Image Links:

3.M64 Android 6.0 HDMI & LCD7

  1. Features Map
  1. HDMI Version Image Links:
  1. LCD7 Version Image Links:

4.FAQ:

  • How-to use ubuntu system to support lcd7?
  1. “vi /media/pi/BPI-BOOT/bananapi/bpi-m64/linux/lcd7/uEnv.txt”
  2. If you use HC070TG lcd7 screen, change “touch=gt9xxnew_ts” But if you use S070WV20 lcd7 screen, you don’t need to change.
  3. “bpi-bootsel /usr/lib/u-boot/bananapi/bpi-m64/u-boot-with-dtb-bpi-m64-lcd7-8k.img.gz”
  4. reboot image

(Gino Giuliani) #2

apt-get does not work on my b-pi is this a known issue or have I got a bad flash? Secondly do you have a link to the build scripts used here?


(ZB) #3

for apt-get not work, please check two things:

1.your board could connect internet.

you could use "ping 8.8.8.8" to check

2.if your board could connect internet, please do “apt-get update” , then use “apt-get install xxx”


#4

Can anyone tell how to get 3,5mm Jack audio output and onboard mic to work. I have tried many different alsamixer configurations with no luck. If i try aplay -vD hw:0,0 test.wav there is no sound.


(ZB) #5

Could you please make sure your earphone plug head is like this:

image

image

if not , you could use earphone has two wires which is seperating mic and L & R like this:

image


#6

IMG_20181019_130939 I have tried both, still no luck.

aplay -l shows:
**** List of PLAYBACK Hardware Devices ****
card 0: audiocodec [audiocodec], device 0: SUNXI-CODEC codec-aif1-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: audiocodec [audiocodec], device 1: bb Voice codec-aif2-1 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: audiocodec [audiocodec], device 2: bb-bt-clk codec-aif2-2 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: audiocodec [audiocodec], device 3: bt Voice codec-aif3-3 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: sndhdmi [sndhdmi], device 0: SUNXI-HDMIAUDIO sndhdmi-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0

aplay -L
null
    Discard all samples (playback) or generate zero samples (capture)
default:CARD=audiocodec
    audiocodec, 
    Default Audio Device
sysdefault:CARD=audiocodec
    audiocodec, 
    Default Audio Device

but aplay /usr/share/sounds/alsa/Rear_Left.wav plays no sound on headphone output.

what am i doing wrong? I have try also with fresh 2018-08-09-ubuntu image with no changes to alsamixer and still nothing.

Is there any alsamixer settings that need to be set in order to get it work?


(ZB) #7

Hello, If you use Android ,Audio Codec is working, But if you use linux , you need to replace asound.state.

asound.state (19.8 KB)

use this file to replace your “asound.state” and “aound.state.bpi-m64” under /var/lib/alsa. It should work. Good luck to you.

image


Banana PI BPI-M64 New Images :Ubuntu16.04 Desktop & AARCH64 Release 2018-11-1
Banana PI BPI-M64 New Images :Raspbian 9.4 Kernel 3.10 & 4.4 Release 2018-11-06
Banana PI BPI-M64 New Images :Debian 9.5 AARCH64 Release 2018-11-02
#8

work like a charm, perfect, thank you.