Was anyone able to get OpenMPTCProuter to work on BPI-R64?

I’m stuck at the point where U-boot asks for the .itb file. I can see that OpenMPTCPRouter’s dev included a .itb file in the download section for the BPI-R64 but the problem is that i have no clue of how I’m supposed to provide it since Ethernet and USB ports don’t seem to be working while I’m in U-boot. I know for sure that it’s possible since there are several vids on Bpi’s youtube channel where they’re using OpenMPTCPRouter on this board, but I wasn’t able to find instructions anywhere. image

You probably need to install using the SD card image downloadable from https://download.openmptcprouter.com/release/v0.58.5/bpi-r64/targets/mediatek/mt7622/openmptcprouter-v0.58.5-r0+16336-b36068d35d-mediatek-mt7622-bananapi_bpi-r64-sdcard.img.gz

That’s the one I’ve been using. Doesn’t seem to be working straight away though, U-boot starts to search for this .itb file and there is no way to boot into OpenMPTCPRouter until it’s provided apparently.

U-Boot trying to download that file indicates that it either couldn’t load the production image from the SD card or that the RESET button was held down during boot. Most likely this pre-alpha image from OpenMPTCPRouter is just broken :man_shrugging:

It tries to load image via tftp from server 192.168.1.254 with own ip address 192.168.1.1

I guess this does not match your network topology. Do you have a tftp server running? If yes you have to change serverip variable in uboot first.

But more likely kernel should be loaded from sdcard,but i do not see this on your trace.

You could try using mmc and ls commands to find a kernel and configure the environment if there is any. Maybe mtd have to setup first

Bad FIT kernel format! (err=-22) very much looks like U-Boot tried bootm on something which it had loaded into RAM before and as that failed, it would resort to TFTP. As this is OpenWrt, I don’t think ls will work as there is no boot filesystem.

I do have a tftp server running but it doesn’t really matter to be honest, the ethernet interface isn’t working at all, I can’t ping the Banana Pi from any host on the network and viceversa. I’m guessing that it actually is a broken image at this point, even though it’s weird that the dev would publish it without even testing it.

you have r64 with mt7531 switch? maybe they forgot to compile driver for it in

source for the uboot is not available?

normally the kernel should be loaded from sdcard/emmc. that seems to fail and the tftp is only fallback (it tries to load a recovery kernel from tftp).

can you get the messages before your screenshot? to see what your image tries to load exactly? else enter printenv (make sure all can be copied => wide window), maybe there we can see whats happening

@dangowrt does ls not work on mtd? have not used it before…but imho it have to be defined first before accessing it so that partitions are clear

He says that it’s untested “Banana Pi BPI-R64 (eMMC not yet tested alpha support)”, see https://www.openmptcprouter.com/download