Using BPI-R2 OTG

I’d like to use OTG on the BPI-R2, preferably with OpenWRT, but some other Linux would be fine. I installed the appropriate kmod packages on the latest OpenWRT snapshot (kernel version 5.15.145) and tried commands like:

modprobe g_mass_storage file=/tmp/mass

Modprobe doesn’t return an error, but I see this kernel error:

udc-core: couldn't find an available UDC - added [g_mass_storage] to list of pending drivers

I tried rebuilding OpenWRT and explicitly enabled the USB gadget kernel modules using make kernel_menuconfig and got the same error.

I read this post from last year, but don’t fully understand what was discussed with DTS.

As my last 2 messages in linked thread says it should be in mainline since 5.16. make sure you have config otions enabled and modules loaded (especially musb-mtk)

Thank you, I misunderstood and thought they were in 5.15. I’ll figure out how to move my OpenWRT build to 5.16.

No i had added the patches to my 5.15…but maybe you can add these patches to your openwrt source…should be only dts patches and defconfig options