USB_Burning_Tool on MI5

Hi, was using Android 9 on eMMC and i want now to switch to a LINUX distro. I am not able to connect MI5 with USB cable with ‘USB_Burning_Tool’ application to ‘Erase EMMC for SDcard Bootup’ , no device seen, (the BPI MI5 i meant) Throught ADB tool > connexion ok In other words i want to remove my Android from eMMC and get installed a Linux, Thanks for your help Tousha

five ways (a,b,c,d,e, e is simplest ) to erase emmc android

Hi, thanks for your reply. None of these 5 work, Facing many error messages about ‘right/permission’ , waiting for devices etc. Even dealing with sudo, root… Dealing with RPI was much easier :slight_smile: Merry Christmas to all

I’m having the same problem. Doesn’t even show up in device manager. Even tried manually install the Amlogic drivers, no luck. Let me know if you found a fix.

What is the problem? I’m unsure when I read this thread so can you screenshot the issue? Didn’t you just successfully install Ubuntu Server on a M5?

Seems clear enough to me, @telefon, I have the same issue. The Bpi M5 comes with Android loaded and there seems to be no way of getting past the Android boot. The Bpi doesn’t appear as a device in USB_Burning_Tool and the instructions for using Uboot or the other tool are not clear enough to follow (I have 30 years programming experience, so a complete novice…) and my PC is not keen on loading them, saying they are known sources of viruses.

I have connected a serial cable and made the link to console, but can’t find and information on what commands to enter to delete the boot sectors.

I’ve downloaded a Raspios image, flashed it to SD and tried to boot from that but guess what? I still end up with the buggy Android OS loading. The image boots fine on a RPI, so it’s not that

Please help us, someone

I’ve found a solution. I tried all the Raspios distros - none of them loaded; it booted into Android from eMMC every time. Then I tried the Ubuntu server distro and that booted correctly. From there, from the command line, i ran

$ sudo dd if=/dev/zero of=/dev/mmcblk0 bs=1M status=noxfer

which never returned, but I gave it five minutes, then turned off, took the SD card out, rebooted and it didn’t boot Android. So I put a Raspios distro on the SD and that booted correctly.

Bit of a bodge, but everything related to this board seems to be that so, hey ho.

Now I need to work out how to copy Raspios into the eMMC - should be a doddle, but none of the online info helps, so maybe not!

Any help greatly appreciated

Good work @chrissaich that you found a workaround, and thank you taking the time to write it in this forum to help others.

USB_Burning_Tool works for me with a normal USB 2.0 Type-C in the M5 and Type-A on my PC. No need for any serial/debug cable.

With that many programming years, perhaps you can understand why I ask for a screenshot to see how the program looks on your side when it doesn’t appear.

Hi @Telefon. If you run USB_Burning_Tool with no BPI devices connected to your network, the device list is empty. That’s what it looked like.

I’ve transferred the Raspios image to eMMC, with a few problems and false starts, but it runs well and when my heatsinks arrive, I’ll try overclocking it and see how it performs. Thanks to the community for previous posts guiding me through the eMMC transfer process.

Hi @chrissaich. If you run USB_Burning_Tool without choosing an image, the device list is empty, That’s what it’ll look like, regardless of devices connected.

Since you don’t feel the need to share a screenshot, I can’t tell if you made that mistake. But really, online helping without logs/screenshots is just a mess.

Hi @Telefon.

The device DID appear the first time I ran it. I uploaded a Linux image (or at least thought I had!) but Android ran subsequently and the device never reappeared.

I did upload an image file, but sadly the device still didn’t appear.

I’m not really in a position to upload an image because I no longer have Android running on it. All I would be showing is an empty USB_Burning_Tool screen (with an image loaded!)