Unable to get external connection (ping Fresh install of Openwrt to BPI-R3 to eMMC

So I did a fresh install of openwrt onto the banana pi r3. I followed the exact steps by Daniel. I connected everything up correctly and it is able to successfully boot from eMMC. But I cannot ping I do not know if I have to adjust any particular configurations. I tried asking ChatGPT-4 for help as well as looked through everywhere to make any adjustments. In the end no dice. So I factory reseted it and I am not sure what to do. I didnt install any update packages (cause cannot connect), I am not sure what I am doing wrong. Please help.

  • You need the USB end of the adapter plugged to your computer.
  • connect RX, TX and GND signals of the adapter to the Debug UART of the BananaPi R3
  • download *sdcard.img.gz file
  • decompress (gunzip) *sdcard.img.gz file
  • write *sdcard.img to microSD card
  • insert microSD card in BananaPi R3 board
  • strart puTTY and select the COM port of the USB to serial adapter, 115200 baud, 8N1 or use minicom on Linux and select /dev/ttyUSB0 .
  • put switches of the BananaPi into position to boot from SD card and select NAND flash with the SPI-chipselect switch
  • now power on the board, you will see U-Boot menu after a short time
  • select Install ... to NAND option
  • once installation has completed (1-2 seconds) you can disconnect the board from power
  • now put switches into position to boot from NAND flash and select eMMC with the MMC data switch
  • connect the board to power again, this time you will see bootmenu start started from NAND
  • select Install ... to eMMC option
  • once installation has completed (1-2 seconds) you can disconnect the board from power
  • now put switch into position to boot from eMMC
  • when you connect to power again, you will see the board booting from eMMC

We need to know your network setup. Please show output of “ip a” and “ip r” and your network config outside r3 (lan-subnet of your main-router which r3 is connected),if you have not connected r3 directly to the public internet. From where have you tried the ping (r3,client behind r3)? If you tried from client its config will be interesting too and then you maybe need a static route in your main-router if r3 has no nat activated.

@frank-w Thank you for taking the time to respond.

Here is the ip r and ip a response. I am connecting from the cable modem ethernet to the wan port on the R3. I am also connected via usb to my pc. I am running the commands by USB serial session. So pretty much as close to a direct connection as I can be. 336655956_160528383595385_940229832067452780_n

Here is the /etc/config/network file. It is the default firstboot version. 336659011_1253227895630779_2156507848317105963_n

Here is the /etc/config/dhcp file. It is the default firstboot version. 336660817_1505976023262479_6894752390530778701_n

how is your network-topology?

lan is configured on r3, but where is your uplink to the internet? br-wan has no ip-address (should get one via dhcp from your main-router as far as i see)…if your main-router is connected to a lan-port (and so br-lan) its lan needs to be too and do not have to be as its own address (because used for br-lan on r3). then your default-route is missing…you have only a route for your lan-segment…for all other r3 system does not know where to send it.

I am so confused. There is no “main-router”.

There are only 3 players.

  1. Cable Modem. (1 Ethernet port)
  2. Banana Pi R3 (Openwrt is installed on this). The WAN port is connected to the Cable Modem.
  3. The PC. The USB is connected from the PC to the Banana Pi R3. The pc ethernet is connected to the Banana Pi on 1 of the LAN ports.

That is it.

My cable modem is not a router. I have another router that is the old one. I am intending the replace that one with the Banana Pi R3 acting as the new router. The old router is not part of the system as of what I written as.

ok, so directly connected to the internet…then you have to create a dialup-connection over the wan-port…this is a bit different from ISP to ISP…here in germany all connections i know are via PPPoE so i guess you need to setup such a connection to your ISPs gateway.

in US there are some ISP which dial in (do not know how exactly) and using dhcp, but this seems not the case here…at least you need to have an interface with your public IP where your default-route needs to point to.

@frank-w Thank you for responding. It actually helped me out. I was confused with each of the different parts. And then I had ChatGpt help me the rest of the way through. There was no issues with the configuration. It was DHCP. My modem assigned DHCP info to the R3. I had to reset the modem and the R3 and it works now. So i was bashing my head for the entire day, just because I did not unplug my modem and replug it in to reset and reassign the values to the R3.

It is working now. No configuration needed. Just that both had to be in sync.

Probably the cable modem distributes exactly one DHCP lease to a connected device. So that means you will either have to clone the MAC address of your old router onto the WAN port of the R3, or simply wait until the lease expired. I’ve seen this many times, it is very common for DOCSIS/cable deployments.