Unable to boot OpenWRT BPI-R2 PRO [Solved]

Hello everyone,

Sorry for my english, I’m a rookie in this world and I’m finding a lot of problems trying to install OpenWRT imagein the R2 PRO.

Basically, at first I was able to install it and I worked with it but after some mistakes I made with the network configuration I wipe the emmc to install OpenWRT again and this is where all the problems began. The tutorials from the “Getting Started” page don’t work anymore:

  • When I try to install from SD card with the “update.img” the android image appears and some messages prompts like “installing boot/ installing recovery/ installing userdata” and finally appears the message to remove the SD card (as in the picture below) and then reboots and it gets stuck in the bpi logo.

  • The same happens with the RKDevTool: i tried flashing the update.img, and also with the EMMC boot files in maskroom and loader mode (this last case after installing Armbian or Ubuntu). After installing it, no error message nowhere, “Download image OK” promtps but then it reboots and gets stuck in the bpi logo again.

I was able to install Armbian with and SD card and then moving it to the EMMC and I was able to install Ubuntu mate with the EMMC boot files and instructions from “Getting Started” and the Usb Download Tool.

I’m stuck now and I don’t have the knowledge to either find the problem or try to make a custum image or edit boot or anything. Please, can someone point me in the right direction?

Afaik openwrt does not support r2pro so will be stuck in an out-of-date system using the bpi image. Imho it is not worth the work.

You can look in my repos and wiki if you find something useful


My uboot also builds a basic image (without kernel and rootfs) where can put an up2date openwrt rootfs (you can build it as tar.gz and unpack to the root partition of the mmc (afair there was no difference between sdcard and emmc) and maybe a kernel from my kernel-repo

Just try to flash the bpi-r2pro*.img to your emmc and look if you get into uboot (my last test is long time ago).

Btw. Screenshot looks like android not openwrt

I’ve open a PR to support OpenWrt on the BPI r2-PRO, is pending to be approved.

1 Like

thanks for this info, wonder why hdmi is not working…it was when i last tried with mainline-kernel

headphone is only speaker, no mic as mic is not connected to the jack, mipi was untested by me, ir afair was working (patch from @deadmeat)

The HDMI It is not an issue with the bpi r2 -pro is a limitation with all rockchip devices on OpenWrt but is not strictly necessary.

ok, right, on headless system hdmi is not required…

btw. the IR-Patch:

All target are moving to v6.6 on OpenWrt the IR patch is already included.

Thanks for the quick answers. I already checked your work, it’s amazing but I don’t know exactly how to do it as I already tried something similar using this tutorial and didn’t succeed:

I’m checking you README.md I will see if I manage to do it. Do you know about some tutorial or something that could help me understand what I’m doing exactly?

Thank you in advance

Easiest way would be cloning

And then building openwrt from it