BPI-R2 OpenWrt(LEDE) Souce code : 2018-04-11

Stateless Ipv6 seems can not work fine. I can get ipv6 address and get default gateway. But when I try to ping gateway. Only “network unreachable” is returned. And also can not ping another device under same switch.

On another device with is work find. I can see many device in Luci -> Status -> Routes -> Active IPv6-Routes.

If I use stateful IPv6. I work fine.

1 Like

Hi, did someone get Luci to work ? I get errors

/etc/rc.common: eval: line 1: /usr/sbin/px5g: not found 
mv: can't rename '/etc/uhttpd.key.new': No such file or directory 
mv: can't rename '/etc/uhttpd.crt.new': No such file or directory

maybe this works:https://forum.lede-project.org/t/luci-with-px5g-error-installing-luci-ssl-in-lede-master-fails/1917/3

Tried few hours until now, nothing worked. Witch source-list do you use guys ?

Yeah, I wasn’t able to get LuCi to work either. :disappointed:

Something with the packages has to be changed, but dont know how and witch is the right one.

I spend a lot of time (the whole Day) to access SSH via WAN and install luci, both didnt work.

Hello! I’ve got my BPI-R2 few days ago, and installed OpenWrt (from google-drive-link)…

And have some question. How i can get packages which I need?.. (bash, screen, uhttpd or apache, rrdtools… …and other…) i do not see so many available packages for BPI-R2 OpenWrt((… but have 8Gb eMMC storage :confused: and a lot free space for packages…

And second question… in description OpenWrt have WIFI Support. But on my OpenWrt I dont see any wireless interfaces (I wish to see onboard wifi in ifconfig)… and no any words about wireless in ‘dmesg’… But on raspbian(debian9) internal wifi works well. My interfaces:

 root@BANANA-R2:~# ifconfig | grep -v "         " | grep -v '^$' |  awk '{print $1}'

Sorry if my question has answers above… But i did not found them.

Hello, Did you try “opkg update” and “opkg install luci” ?

Here is my luci page: image

hello, Please see this link: BPI-R2 new image: Ubuntu with Linux kernel 4.14 release V1.0 2018-4-28

it’s almost same ways to open AP mode. if you have any questions please let me know.

I think all knows how Luci looks like :slight_smile: and commands to install…
But our OpenWrt does not have repository with correct LuCI package;
can you show result of commands from your BPI-R2 with OpenWRT:

cat /proc/version    
cat /etc/opkg/*.conf

it more helps for all who want to install LuCI;

Thank you for your answer!

My OpenWRT:

root@BANANA-R2:~# cat /proc/version
Linux version 4.9.44 (gary@gary-HP-Z238-Microtower-Workstation) (gcc version 5.4.0 (LEDE GCC 5.4.0 r4768-b1d4a37) ) #0 SMP PREEMPT Wed Jan 10 17:09:53 2018

and it does not have commands from your link:

root@BANANA-R2:~# stp_uart_launcher
-ash: stp_uart_launcher: not found
root@BANANA-R2:~# which stp_uart_launcher

and there NO device /dev/wmtWifi

root@BANANA-R2:~# ls /dev/wmt*

Internal WIFI still not work;

Hello, Did you build-in “CONFIG_PACKAGE_wmt=y” in your “.config”?

you could see steps here:

1 Like
root@OpenWrt:/# cat /proc/version
Linux version 4.14.36 (root@JackBpi) (gcc version 7.3.0 (OpenWrt GCC 7.3.0 r6767-50b0919))  #0 SMP PREEMPT Fri Apr 27 07:59:33 2018
root@OpenWrt:/# cat /etc/opkg/*.conf
# add your custom package feeds here
# src/gz example_feed_name http://www.example.com/path/to/files
src/gz openwrt_core http://downloads.lede-project.org/snapshots/targets/sunxi/cortexa7/packages
src/gz openwrt_base http://downloads.lede-project.org/snapshots/packages/arm_cortex-a7_neon-vfpv4/base
src/gz openwrt_luci http://downloads.lede-project.org/snapshots/packages/arm_cortex-a7_neon-vfpv4/luci
src/gz openwrt_packages http://downloads.lede-project.org/snapshots/packages/arm_cortex-a7_neon-vfpv4/packages
src/gz openwrt_routing http://downloads.lede-project.org/snapshots/packages/arm_cortex-a7_neon-vfpv4/routing
src/gz openwrt_telephony http://downloads.lede-project.org/snapshots/packages/arm_cortex-a7_neon-vfpv4/telephony
1 Like

I do not understand which about file do you write… (you did not write full path to .config)
and it difficulty to answer;

i write image: mtk-bpi-r2-EMMC.img directly to eMMC using dd (previosly booted from SD-card)…
mtk-bpi-r2-EMMC.img I downloaded here: https://drive.google.com/drive/folders/1yEP6o3EGhICOV2DJRW-eqDg0vO_xK1Mg

no any configs I did not edited.

Can you tell where you get this image:
Linux version 4.14.36 (root@JackBpi) (gcc version 7.3.0 (OpenWrt GCC 7.3.0 r6767-50b0919)) #0 SMP PREEMPT Fri Apr 27 07:59:33 2018

or is it self compiled?

Hello, cement, this image is for my testing, I will show you Luci steps with this source code.

thank you…
but LuCI not important for me…
More important WIFI Support and and lot of available packages.
for now I can install only this packages:

1.make menuconfig

2.Choose Utilities->wmt


Sorry… may be I live in forest.:monkey:
I really do not understand how you got this window…
all my previously images i wrote using dd (it was ready images from other peoples… I did not compile myself any custom images before)