BPI-R2 OpenWrt(LEDE) Souce code : 2018-04-11

These are the patches that are not working correctly…currently i have response from john,lede-team or sean about the damaged packets

Please fill in the normal file hosting. From Baidu or torn or archive the bad and is not unpacked.

Hi Garywang

updated downloaded from https://downloads.openwrt.org/snapshots/targets/mediatek/32/openwrt-mediatek-32-bananapi,bpi-r2-sysupgrade.tar. Does not start the kernel panic, is it not compatible with your build?

Did you choose Boot Loader?

you could execute make menuconfig

Choose : Boot Loader —> u-boot-bpi_r2

then you could build successfully.

I don’t think it’s compatibile

We found a tool mmc-utils that is for configuring MMC storage devices from userspace, so we can change the Boot Partition setting in userspance.

How to build it

  1. install by running below commands ./scripts/feeds update -a ./scripts/feeds install -a

  2. Select in menuconfig make menuconfig -> Utililes -> mmc-utils

  3. Rebuild Openwrt project

How to use it

1 .mmc extcsd read /dev/mmcblk0 | grep PARTITION_CONFIG Boot configuration bytes [PARTITION_CONFIG: 0x00]

  1. mmc bootpart enable 1 1 /dev/mmcblk0

  2. mmc extcsd read /dev/mmcblk1 | grep PARTITION_CONFIG Boot configuration bytes [PARTITION_CONFIG: 0x48]

After finishing above steps, the board can boot from eMMC, so we don’t need enter u-boot shell to change PARTITION_CONFIG.


Software environment

  • System: Linux LEDE 4.9.44 #0 SMP PREEMPT Fri Apr 13 13:46:33 2018 armv7l GNU/Linux
  • Firmware: All intel firmwares are installed
  • Kernel module: All dependencies are installed

I insert Intel Dual Band Wireless-AC 7260 NIC into BPI-R2. Use lspci can see the network card but use ifconfig -a can’t find it. I check the system log(/var/log/messages). It reminds the missing “iwlwifi-7260-17.ucode” file. I find and copy this file to /lib/firmware and reload modules.

insmod iwlwifi.ko
insmod iwlegacy.ko

Terminal output

failed to insert iwlegacy.ko

System log(/var/log/messages)

Apr 19 11:19:59 LEDE kernel: [ 200.968773] iwlegacy: Unknown symbol __ieee80211_get_radio_led_name (err 0)

insmod iwlmvm.ko

Terminal output

failed to insert iwlmvm.ko

System log output(/var/log/messages)

Apr 19 11:21:42 LEDE kernel: [  303.969064] iwlmvm: Unknown symbol ieee80211_wake_queue (err 0)
Apr 19 11:21:42 LEDE kernel: [  303.999996] iwlmvm: Unknown symbol ieee80211_sta_set_buffered (err 0)
Apr 19 11:21:42 LEDE kernel: [  304.019293] iwlmvm: Unknown symbol ieee80211_stop_tx_ba_cb_irqsafe (err 0)
Apr 19 11:21:42 LEDE kernel: [  304.057047] iwlmvm: Unknown symbol ieee80211_sta_block_awake (err 0)
Apr 19 11:21:42 LEDE kernel: [  304.070646] iwlmvm: Unknown symbol ieee80211_sta_pspoll (err 0)
Apr 19 11:21:42 LEDE kernel: [  304.120227] iwlmvm: Unknown symbol ieee80211_stop_queue (err 0)
Apr 19 11:21:43 LEDE kernel: [  304.158954] iwlmvm: Unknown symbol ieee80211_sched_scan_results (err 0)
Apr 19 11:21:43 LEDE kernel: [  304.179765] iwlmvm: Unknown symbol rate_control_send_low (err 0)
Apr 19 11:21:43 LEDE kernel: [  304.198025] iwlmvm: Unknown symbol ieee80211_resume_disconnect (err 0)
Apr 19 11:21:43 LEDE kernel: [  304.211234] iwlmvm: Unknown symbol ieee80211_tdls_oper_request (err 0)
Apr 19 11:21:43 LEDE kernel: [  304.256943] iwlmvm: Unknown symbol ieee80211_rx_napi (err 0)

There is still no way to load this wireless network card. Help me!!!

you must want to enable


in your kernel

to add the unknown symbols and allow your added module able to reference to them.

Except for kmod-mac80211-hwsim and zabbix-extra-mac80211, other options about mac80211 are enable.

zabbix-extra-mac80211 is not set
kmod-mac80211-hwsim is not set

But it still can’t work.

Please upload this image on Google Drive/Microsoft OneDrive, Baidu is not available in every country, and there’s no option to change the language to English.

1 Like

I try to build a new image to my BPI-R2 but the Intel 7260 can’t work.

Hi Symowl

BPI-R2 doesn’t support Intel PCIe card, this is a hardware limitation, we can’t fix it in software level.

So, Gray Wang, Could you tell me the supported mini-pice WLAN model list in R2 ? Because we want to give up the MT6625L onboard.

Another question:

  1. the Onboard wifi chip MT6625L only working in 2.4G or 5G, can’t work in double frequency?
  2. During we test throughout performance in 5G, we found the wifi crash when download speed in 50 Mbps. It is right ?

Thank. I tried to install other wireless network cards. Do you know the wireless network cards it supports?

We are looking for replacement of MT6625L, now we are developping a WIFI module(PCIe) based on MT7615 and we’ve validated RTL8723BU(USB).

I think the WIFI module based on USB should be supported, but the driver is required. Why the Intel WIFI(pcie) is not support is that the pcie device of it is invisible for MT7623N chip. Also we’re validating the WIFI module(PCIe) from RTL and BCM.

Image in Google Drive: https://drive.google.com/open?id=1yEP6o3EGhICOV2DJRW-eqDg0vO_xK1Mg

Thank you for on-time wifi info. So would have plan to make BPI R2 new hardware version(> v1.2) for changing onboard wifi module?

The module based on MT77615 is an optional module(PCIe), we don’t have plan to change the onboard wifi module

Hi Symowl

We validated the following mPCIe modules(PCIe), they are visible for sytem, we don’t validate them with driver.

  • Intel 512AN_MMW
  • RTL 8191SE
  • BCM4313

Unsupported Module we found so far:

  • Intel AC 3160
  • Intel 7260 AC