The U-Boot boot menu does not appear when turned on

The U-Boot boot menu does not appear when turned on. Launch PuTTY and select the “Serial” option. I then select the appropriate COM port and set the speed to 115200. Finally, I click Open to continue. While Putty is running in the background, I connect the power supply to the board to start downloading. But the boot menu does not appear. USB-RS232 Dongle works correctly. Tell me how to restore the Pi BPI-R4.

Bpi-R4? Which image? Which boot device? Do you see anything else (bootrom)?


connect to BPI-R4 DIP - SD terminal Снимок экрана 2024-03-01 в 10.23.28 Снимок экрана 2024-03-01 в 10.23.39 Снимок экрана 2024-03-01 в 10.23.54 Снимок экрана 2024-03-01 в 10.26.07

Mhm at least bootrom should be seen even without card/image…is the power-led lighting? Uart connection (rx-tx,tx-rx)/settings (115200 1n8) seem to be correct.

But i can say that profilic uarts caused wifi issues on r3…i have not heard anything for r4 yet,but it is similar soc and still ftdi is recommended.

What is your powersupply? 12v/xA on the barrel connector or usb-c with which spec? I do not see any.

Power supply - Baseus GaN 65W type-C , 5V/3A, 9V/3A, 3.3-11V/2.7A, 3.3-11V/3A, 12V/2.5A, 12V/3A, 15V/2A, 15V/3A, 20V/1.5A, 20V/3.25A . At the output of the power supply when connected to BPI-R4 - 12V/3A.

was your terminal active while poweron?

if boot hangs there is no further output and you see nothing if terminal was not ready on output…so first connect terminal and then poweron

I did everything according to the manual - first started the terminal and then supplied power to the Pi BPI-R4. There are no symbols in the terminal window, the menu is not displayed.

very strange because bootrom is independ of the image/card and should always be displayed.

i guess something is wrong with your uart adapter

1 Like

Tried different usb-ttl, same result

I tried different usb-ttl, the result is the same in the terminal window there is no boot menu.

be careful because of some adapter have 5v ttl…bpi boards are 3v3 level, you may brick the uart in soc when using 5v signals

Thus, this company’s product, intended for the trash bin, is nothing more. Sorry I spent a lot of time and money.