[Solved} [MSi Motherboard] WiFi Upload Speed Issues / Banana PI R3 / OpenWRT

Hello, I have just finished setting up a new Banana Pi R3 with OpenWRT 23.05.3.

I have 2 access point, a WiFi 2,5 GHz and a WiFi 5 GHz which is where the issue stands.

The issue

When connecting my android phone over WiFi 6 on 5GHz, I get speedtest results of up to 900 mbps download and 800 mbps upload. When doing the same test with my PC, from around the same distance, I get 900 mbps download and 5 to 10 mbps upload.

What is strange is that this very same Windows 11 Device has the exact same drivers, Windows version and network that I had before installing the new Router, however before although the download speed would top at around 600 mbps max, it would also reach about 500 mbps upload.

I have tested another Windows 10 device, which seems to have the reverse problem, about 3 (!) mbps download and 300mbps upload (latter probably limited due to the wireless adapter).

OpenWRT configs

Here are my Access Point configurations:

  1. Mode AX
  2. Channel 52 (according to the graph, the most free channel)
  3. Width 160 MHz (to reach higher speeds)
  4. Maximum transmit power: default, 20 dBm
  5. Country Code: it has been set (IT)

I would expect these to be ok, considering that my Android device works fine.

Client specs

On the Windows 11 device, I’m using an Intel WiFi 6 AX201 160 MHz. The problem was there with the default drivers and even after uninstalling the old drivers and reinstalling the latest version directly from the Intel website, the issue persists.

I don’t understand where the issue could be, my PC worked fine with the older access point, but the current access point works fine with other devices, same distance, even smaller antenna.

This is very problematic because I do need OpenWRT or anyway at least another firmware since my ISP stock firmware is far too limiting. Does anybody have had experience with this in the past?

Thanks in advance!

did you try to reset the TCP stack ?

in windows 11, in command shell :

  1. Type: netsh winsock reset in the shell and hit Enter
  2. Type: netsh int ip reset and hit Enter again.
  3. Restart the computer


I forgot to mention that I had tried a network reset from the settings (suggested on some Microsoft forum) and it didn’t help.

I tried running your commands on a shell as admin but unfortunately there was no difference (2~3mbps up which is worse than before but within margin of error).

I have read that some people have had problems with WPA3, I have enabled both WPA2 and WPA3, but I have no way of checking which is being used (as far as I know on Windows at least), I have the suspicion (or rather, the hope) that the issue is WPA3 somehow causing performances issues.

My phone is using WPA3 and is going fine, maybe the support on Linux/Android is better? Not sure…

I will try switching to WPA2 when I won’t disturb the other users and will update here if it does make a difference.

Thank you by the way!

i’m actualy with OpenWrt 23.05.2 and i don’t see any problem. could you try to downgrade to this version maybe ?

Anyway, this is my configuration for the 5Ghz band :

The driver default for my country is 23dBm which is twice as powerful than 20dBm…i’m surprised that your country asks for such a low limit.

Can you try to force the channel 36 ?

I could try switching it, but not at the moment since other users are connected and I can’t cause offline times for too long… I’ll try it when I can and see if there is a difference!

As for channel 36, I’ve been there for a while but I had worse download performances (makes sense, according to the scan most routers seem to be on channel 36), about the same upload performances.

As for the Maximum Transmit Power, 20dBm is the highest option I can pick with my country code, I tried selecting FR myself, but even after applying and refreshing the page the highest option was 20 dBm 100 mW.

Do you happen to have any specific settings on the advanced settings?

By the way just as a side note, I did try switching to WPA 2 only, sadly, no improvement whatsoever.

Edit: The locked maximum transmit power may be caused by the used channel, I will try going back to channel 36 and see if the maximum value changes as soon I can.

By the way, thanks for the help!!

Nothing special in the advanced settings, only VMM mode is checked.

If i remember well you have to set the country code on both 2.4ghz and 5Ghz.

And by the way if you want to unlock all the power of your wifi, you can set the country code to PA (Panama). you’ll be able to get 30dBm if i remember well, so you’ll send your wifi all over your city :rofl:

Hello, I have done some tests to report:

I tried changing the country code to Panama, I do now have a maximum of 27 dBm, it seems like the WiFi signal is a bit stronger but performances in both Upload and Download did not really change.

I tried changing the bandwidth from 160 MHz to 80 MHz (I know, it’s counter intuitive, but hey, I’m desperate), significant slowdown on Download (as expected), same performances on upload.

I tried changing the WPA again (before I set WPA2 only, now I set WPA/WPA2 mixed), it shouldn’t make a difference for the way I set it up and in fact… it didn’t.

I’m very much lost, I’m not a WiFi expert, but if it works at high speed on download I don’t see why it wouldn’t work during upload.

I do know that WiFi depends on a variety of factors, but a similar device, with the same antennas (though, on Linux with a different wireless card, also from Intel) works… better.

And in all of those tests I’ve also checked the actual Internet speed test directly from the Router with the same speed test server, 1gbps up, 1gbps down…

I think WiFi hates me…

Thanks for all the support, more ideas are always welcome! I’ll try new stuff and see what happens.

you’ve tried everything on the router side, i think the problem is your PC or windows. What about booting your PC with a live usb of ubuntu ? https://ubuntu.com/tutorials/try-ubuntu-before-you-install#1-getting-started

that way you could see if the problem is driver based.

I’ll try that!

But the weird thing is, the more I’m using this router, the more those performances issues start to rise with other devices (other Windows laptops, but not all of them, and a PS5).

It definitely is some kind of driver issue or incompatibility issue with the devices I’m using, since other devices are going better than ever, but whatever problem that is it’s common enough to the point where I need to somehow fix it router side.

I’ll have to check whether I can get some more info about the old router access point… but as usual, that’s all locked off… thanks ISPs!

I wondered if it might be a firewall issue (too many rules?) but the CPU is always very low usage and the firewall is set to default (and more over, the Android client has no issues).

Very weird :frowning:

The problem has been solved, and I have no words.

So, turns out, that the issue lied on my Motherboard or more specifically, a Software that my MSi Motherboard auto installed when I installed Windows 11, also known as, Dragon Center.

Now, I uninstalled Dragon Center a long time ago, because for me, it was useless, however, apparently Dragon Center or Software Center or whatever did something that slower down my network speed significantly.

The solution? I reinstalled dragon center, open the Lan Manager tab and disabled it, speed works fine now.

The subpar performances of the Intel BE200 on Linux might be caused from some other driver option that I’m still investigating, the PS5 needs further testing.

Anyway, long story fault, it wasn’t the Banana Pi’s fault, it wasn’t Intel’s fault, and it wasn’t even Microsoft faults! It wasn’t even my neighbors fault… it was MSi’s fault…

This motherboard becomes worse and worse of a disappointment every day, even though the issue wasn’t the motherboard in itself but a software.

@Rooot thank you for all the time spent trying to help me, I wish you a great day and a great weekend.

1 Like

I’m glad you were able to solve your problem! :grinning: