[SOLVED] Can't work with emmc

Hi all!

I can’t get bpi-m4 working with emmc boot. Here is what I do: -----all my work is with ssh -------

  • created SD with ubuntu 16.04 server image (2020…ubuntu…sd-emmc…img)
  • Booted ok, I can reach bpi via ssh
  • Copied same image to USB
  • Put USB in bpi-m4
  • mount USB.
  • bpi-copy the image in usb.

bpi-copy start the job and at the end says OK!! You can remove the BOOTDISK /dev/mmcblk1 now!! Is this allright?

Then, shutdown, removed SD, power on and bpi-m4 even not ask for IP from the dhcp. Green led is blinking, yellow led in LAN is blilnking.

Can anyone help me?

Edit: Sometimes emmc boots fine, but sometimes too, ssh tries throw “connection refused” or “connection reset by peer”. I think that board it is faulty. Even lshw shows 648 MB of RAM, and it is supposed a 2GB one. any idea?

meminfo after ubuntu server bootup without any user tasks

MemTotal:        1609848 kB
MemFree:         1453056 kB
MemAvailable:    1330864 kB

make sure your board is 2GB? you should connect a uart debug cable and provide the whole debug messages.

Thankyou August

trying with ubuntu 18.04 mate desktop in the sd card, I get this: imagen

The bpi purchased “must” be 2GB, no indications in the box, but I believe that these are 2GB of RAM:

Also, I’m looking for a uart cable, only I can’t remember where it is :upside_down_face:

This is the output of lshw


It’s a 1GB board, 696 total because about 328 reserve to a special bluecore processor of rtd1395

Thanks fot the information.

[SOLVED] It was a problem with the img file. The first two of three downloads, hash was incorrect. The last download was OK and now emmc is working well.