Soft Raid works

To whom it may concern: Software Raid works fine, but with about half speed :wink:

Hi, How is your construction? Both sata or aditional controller? how powered? Which raid-level?

which Kernel/Kernel-modules?

Regards Frank

Hi Frank, there’s not much construction anyway. I used both sata connectors for 2 identical 320 GB Notebook Drives which I found in the workshop. The second Drive is indeed powered by the “Fan” connector. (Found out by risking an old HDD) I think, the “Fan” Label might be wrong. :wink:

I use the original Ubuntu image, regularly updated. No modules, no nothing just mdadmin creating a RAID1. I defined 3 mirrored Partitions: /var, /home and /Data. Thus, I can boot from the first SD-Card-Partition, mount / on the single 8GB Partition on the emmc-chip and then /var, /home and /Data from HDD. This gives me the following opportunities: the SD-Card is readonly (longer life :wink: ) The System as such is located on the relatively fast EMMC, and having /var and /home on HDD gives me a bit more space on emmc.

Too sad ich can’t append Pictures here, but if you like, you can take a look here:

Hey cool, didn’t know this would work :smiley: Have a perfect new year with plenty of free hours for your family and the R2 :slight_smile:

yours Thomas

1 Like

I assume that the fan is pwm…but i have no oscilloscope here to check that.

did you install to emmc via bpi-copy or manual?

How is the display connected and controlled (gpio seems not connected)?

also a happy new year to you and your family.

If the “Fan” was PWM (as I expected too) shouldn’t the HDD die after a couple of days? I really could imagine it’s just labelled falsely. But - to make sure - in a final rack-mount I will take care of that and give the drives a serious power-supply. (I already have something in mind)

I didn’t use bpi-copy, I made one linux partition on the EMMC and made it the root partition while booting. With rsync -ax I copied the root partition from the SD there. And ever once in a while I make a Backup of the EMMD back to the SD.

As I couldn’t activate I²C (you remember that other thread) I had to attach the I²C-Display to an Arduino, which is attached to the R2 via USB. On the Arduino there is a simple program listening for a line and displaying it on the first line moving the older lines down. Thus, I must not care about the Display programming and have a simple Python script reading mqtt-messages and serial print the new line to the arduino :slight_smile:

Are you are using RAID 1?

Yep, I do :slight_smile: But obviously the power-connector labeled “Fan” was not a good idea. It worked, but it was never reliable. What I need is the harddisk cabeling for the second power output. As long as it worked, it worked fine :slight_smile:

Could you tell me what kind of connector I need for that 4-ping connector? 4x 1.25mm? 4x1.5mm???

Could this one fit?

60 Pieces??? :open_mouth: Jesus!!!

Okay thank you :slight_smile: maybe I get a few somewhere :slight_smile:

I’ve just ordered some :smiley:

I can send you some,but crimping is a bit tricky…and i thinks it’s not cheaper

No thank you, I found them a bit cheaper, and I’ll need those things ever once i a while :slight_smile:

Do you want to use the power supply from 4-pin header on R2, right?

if yes, it’s the 4x2.54mm.

And please note that the FAN connector is to connect FAN, and the voltage can be adjusted by PWM, and I’m not sure if it’s stable for hard drive.

Thanks Gary

I’ve tried to use the “Fan” connector for a Harddisk because the usual HDD cables have those 2-pin connectors. Additionally, when this neat aluminum case was first shown to us, I believe it was cabled like this.

Somehow it worked, but not reliable. Now i have ordered a couple of 4-pin connectors. When they arrive (which will take some time) I’ll give it another try. If raid 1 will prove reliability and performance over time, one could use the R2 as a Nas-system. which might be interesting.

1 Like

Have you added something to my kernel-config to get raid working?

Sorry, haben´t done it yet. In summer my motorbike and my boat have some attraction too. But when i tried with your 4.14 repo I found i must start from Scratch, because there was no .config file

we needed CONFIG_DM_RAID and CONFIG_MD_RAIDxxx too