Slow performance

I instaled a Debian 10 Kernel 5.4 image from https://wiki.banana-pi.org/Banana_Pi_BPI-R64#Debian in my new BPI R64 v1.1 's SD, but i’m getting a very slow performance: high latency, CPU usage at 100% during a package update or install , slow serial response… etc. My CPU temp is always under 57 Celsius degree . I tried other image builds ( also tryed with Ubuntu 21.04 ), with same slow performance. Any ideas about cause?

could you try my buster-image?

https://forum.banana-pi.org/t/bpi-r64-debian-buster-with-new-bootchain-and-linux-5-10/11850/20

apart from that there is a bug in mainline-kernel with thermal zones

Yes, I already tried your image. It was my first choice, with same bad performance. I noticed than it was a unfinished work only for testing but I need some estability due I 'm working at my degree thesis with it. Then I tried the second image, whith kernel 5.4. with same issues. I’m going to aply your patch just now. I’ll keep you noticed.

Something went wrong…

[email protected]:~# patch --dry< arm-dts-mt7623-increase-passive-cooling-tripp.diff can’t find file to patch at input line 5 Perhaps you should have used the -p or --strip option? The text leading up to this was: -------------------------- |diff --git a/arch/arm/boot/dts/mt7623.dtsi b/arch/arm/boot/dts/mt7623.dtsi |index b7247ab082aa…11933494e03d 100644 |— a/arch/arm/boot/dts/mt7623.dtsi |+++ b/arch/arm/boot/dts/mt7623.dtsi -------------------------- File to patch:

is /usr/src/BPI-R64-bsp-5.4_built/linux-mt/arch/arm/boot/dts/mt7623.dtsi the correct file?

For r64 you hve to change mt7622.dtsi. so just use erics patch

It is in arch/arm64/boot/dts/mediatek

Sorry, Frank, but I’m not expert… I’ve got downloaded the correct mt7622.dtsi from https://git.kernel.org/pub/scm/linux/kernel/git/thermal/linux.git/tree/arch/arm64/boot/dts/mediatek , and now i guess must to copy it at /usr/src/BPI-R64-bsp-5.4_built/linux-mt/arch/arm64/boot/dts/mediatek/mt7622.dtsi and recompile my kernel. Is this correct?

As a first step you should execute this line multiple times to check if you are affected by temp bug

 echo "TEMP:" $(cat /sys/class/thermal/thermal_zone0/temp) "Freq:" $(sudo cat /sys/devices/system/cpu/cpufreq/policy0/cpuinfo_cur_freq)

And compare to the values from the thread. If you are affected,just change the first 2 cooling trips like eric does in the dtsi of your repo. Imho it is enough to only compile the dtb

make ARCH=arm64 CROSS_COMPILE=xxx dtbs

Replace xxx by name of your crosscompiler without gcc,e.g. aarch64-gnu-linux-

And then copy dtb to your sd card

I’m getting this values…

TEMP: 55800 Freq: 119999 TEMP: 56100 Freq: 119999 TEMP: 55800 Freq: 119999 TEMP: 55800 Freq: 119999 TEMP: 55800 Freq: 119999

They are not correct, is it?.. altough I’m using your image with kernel 5.4 were you already included this patch ( [BPI-R64]Only 10% cpu speed at already 48 degrees celcius, speed not increasing anymore )

afair the patch was later and not included in one of my images…you have to add patch to a tree and compile it by yourself…i did some tests, but not added it to my tree yet

Hi Xavier. The frequency is throttled to the lowest value. This indicates that you need the temperature patch as well.

except the thermal problem (i have not merged patch because it disables 2 lower cpu-trips completely waiting for information from mtk about right way…still none) i see another possible slowdown here:

http://lists.infradead.org/pipermail/linux-mediatek/2021-October/030805.html