Second wired network interface not working


Is there any trick to have the second network interface (GbE) working?

I am using the provided ubuntu image running kernel 4.9.119, running from a microSD card but typing ‘ip link show’ only shows me eth0, it doesn’t show eth1.

Thank you

go back to older installation method (kernel 4.4). there is no HDMI on it but both eth interfaces work.

Is the kernel source and toolchain available? I need it to build several modules and options in the kernel

Hello, Have you tried to compile and install the new version od kernel from GitHub? Does the 2nd wired network work with the latest kernel? If not where to find the kernel 4.4 as an image?

With new kernel from github does not work either (btw it takes about 51 minutes to compile in the w2 if you don’t want to setup cross compiler). The old image you can find in an early post, just get the complete SD image and get the image and dtd file from the 1st partition of the sd and the corresponding dir from /lib/modules.

Hello sinovoip? …

No answers on this one? Is any work getting the “basic” features of this board going on? I see no update on github since the code went up 2 months ago, no new post regarding work on images …

Could I at least send you a kernel “.config” file with several options enabled and you compile it against your older kernel and provide an image? (and maybe also with less memory dedicated to the GPU since the hdmi will not work anyways)

Thank you

I also have the preblom ,how do you fixed it ?

I didn’t. There’s no fix except by sinovoip. AFAIK the hardware description, firmware details and access to Realtek RTD implementation aren’t something that is publicly available.

And if you move to an older kernel to have both interfaces, beware and set your mac address manually on the ifup scripts. I have a few of W2 boards with me and noticed that the MAC address 00:10:20:30:40:50 are the same on all them and was debugging “weird” errors until I’ve figured that out.

To be honest (and sad), the board have lots of potential on the hardware, but there’s still a lot (in development terms) to be finished and I’m getting the impression that they won’t finish it before the board is not relevant anymore (for example, hardkernel have released on 27/11/2018 a x86 based 14W board with dual ethernets and dual satas. Pine’s Rock64 Pro have single eth but an open slot pci-e 4x, which you can put a cheap sas/sata board if NAS is your thing).

It would be awesome if someone could publish what is currently being worked on (in terms of priorities) and kinda (rough) expectation … I would really appreciate it so I could know if I should hang in there with my projects or move on to some other board (I’m waiting for my H2 board to arrive).

I wished to put together a 7-10 nodes GlusterFS+Samba server but without kernel sources to compile the modules, they are of very little use to me.


I Want to know when hwnat for eth1 support will be added to kernel? This board is useless for me without secondary lan. Do you have kernels for ubuntu or suse or other linux dist with working secondary eth?

1 Like

It seems there is no any product (for sale) using RTD1296 HWHAT, so RealTek won’t release the HWNAT driver for open source.