R2: Bootloop with Openwrt snapshot and kernel 5.10.72

I built my own image for R2 using my recipe here in the forum. But since 4 weeks new built images running in an bootloop, log is here:

[   17.312105] mt7530 mdio-bus:00 lan1: Link is Up - 1Gbps/Full - flow control rx/tx

[   17.319280] br-lan: port 1(lan0) entered blocking state

[   17.332015] br-lan: port 1(lan0) entered forwarding state

[   17.338633] br-lan: port 2(lan1) entered blocking state

[   17.343960] br-lan: port 2(lan1) entered forwarding state

[   17.391624] mt7530 mdio-bus:00 lan2: Link is Up - 1Gbps/Full - flow control rx/tx

[   17.399818] mt7530 mdio-bus:00 lan3: Link is Up - 1Gbps/Full - flow control off

[   17.407528] br-lan: port 3(lan2) entered blocking state

[   17.412824] br-lan: port 3(lan2) entered forwarding state

[   17.418774] br-lan: port 4(lan3) entered blocking state

[   17.424081] br-lan: port 4(lan3) entered forwarding state

[   17.471449] mt7530 mdio-bus:00 wan: Link is Up - 1Gbps/Full - flow control rx/tx

[   17.478930] IPv6: ADDRCONF(NETDEV_CHANGE): wan: link becomes ready

[   22.448267] sd 1:0:0:0: [sda] Synchronizing SCSI cache

[   22.531215] reboot: Restarting system

Luckily I have a running system on emmc, so I could compare the bootlogs. I find no difference between the protocols, but

  1. sd 1:0:0:0: [sda] Synchronizing SCSI cache is missing in the working image.
  2. IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready is missing in the failing boot

As I remember, my .config has no alterations (ok, I added Midnight Commander). sda is Samsung 870 QVO 1 TB. I tried the image from the openwrt site, but this HAS to burned to mmc0 before boot. I would trash my running image, so it´s not an alternative

With regards Gotthard

Have you soldered powerbutton?

No. Board is original from seller.

I’m not sure what triggers reboot in openwrt. I only noticed a warn_on in 5.10.60

kernel/kthread.c:83 kthread_is_per_cpu

But imho this is fixed in an 5.10.7x version

https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/kernel/kthread.c?h=linux-5.10.y&id=709c162ddc835613112bdd2db15b7d04e10c9bbf

But this was not happen on reboot in my case…only after some time.seems to be fixed since 5.10.62

booted my 5.10.75, without issues…your issue is maybe caused by openwrt patches. but without a trace or any info in bootlog i cannot say whats the problem

Is there any kernel boot parameter to set bootlog to higher verbosity? ATM I’m compiling every week a new kernel just to see if the problem is fixed accidentally.

https://www.kernel.org/doc/html/v4.14/admin-guide/kernel-parameters.html

loglevel is verbosity, but errors/critical shown always…so it’s unclear, why your system restarts

Does the reboot also happen without the disk connected? It could be it’s simply drawing too much current on 5V…?

I also run the BPi-R2 with OpenWrt, currently Linux 5.10.76 with two HDDs connected (using an additional 12V/5V power supply for those 3.5" SATA disks). It works fine for me.

Does the reboot also happen without the disk connected?

Not tested yet. Does we have a higher power comsumption with the younger builts? I will check and report this. ATM I have a 12V/2A power source, enough in the last 2 years.

Just tested: no change in behavior with stronger power supply (12V, 3A) also w/o SSD

reboot is stable…

That´s a bad message… Should I trash my build environment and start from scratch?

You can try to increase your loglevel,but i guess you will not anything related.

Could you post your full dmesg? Afair openwrt reboots automaticly on some problems…maybe you can disable this automatic reboot and dig into the system for more information (if system has reached login)

Btw. I run now my 5.10.76 kernel without problems.

You can try bootup an other image,e.g. my debian with a newer kernel.

No login, ergo no dmesg. I have serial console, but the reboot occurs before I have access to cli.

Can you scroll back in serial terminal? I guess error happens before your snippet (like error mounting rootfs,but brlan is userspace config,so rootfs seems not the cause)

here´s the full bootlog bootlog.7z (11,1 KB)

I found this line: MTK_PMIC_RST_KEY is used for this project!

also this [ 0.000000] Linux version 5.10.72 ([email protected]) (arm-openwrt-linux-muslgnueabi-gcc (OpenWrt GCC 11.2.0 r17554-da5bb885e1) 11.2.0, GNU ld (GNU Binutils) 2.37) #0 SMP PREEMPT Wed Oct 20 12:04:40 2021

Build version is wrong, has to be 17781

Please press Enter to activate this console.

looks like you can enter the console…

I’m not openwrt expert, but it looks like only kernel and “preinit” (i guess some kind of initramfs) is booting, not the “real” openwrt system

squashfs is loaded readonly, but i don’t see the switch to write-mode (it should be right?) or is the f2fs the writable overlay?

F2FS-fs (mmcblk1p66)

i guess there is something wrong with the writable overlay-fs which triggers reboot

Problem solved by trashing buildroot and start from green lawn. Build 18014 now running (with new minor problem in https-ciphers and firefox 94).

1 Like