Problem with BPI-R3 and sfp module

Hi. Got DFP-34X-2C2. And it worked with BPI-R3. But then I picked LAN_SDS_MODE = 4 (default was 3) on sfp module. And now I can’t connect to it.


Can I connect somehow to that module now? Does BPI-R3 support this “HiSGMII PHY” mode?

Here is ethtool eth1 output: Screenshot%202023-06-27%20203419

I says “Link detected: yes”. So why can’t I connect to it?

Also no Rx on eth1:


From syslog:

Tue Jun 27 23:13:37 2023 kernel: [ 24.870354] mtk_soc_eth 15100000.ethernet eth1: Link is Up - 2.5Gbps/Full - flow control off

Tue Jun 27 23:13:37 2023 daemon.notice netifd: Network device ‘eth1’ link is up

Can I fix it somehow?

I saw people here with same sfps and they didn’t experience any problems with LAN_SDS_MODE 4, 5 or 6.

Well, it seems, uart is an only option now:(

I’m not sure what exactly you set here…communication with sfp is i2c. Maybe LAN_SDS_MODE switches to inband mode,so maybe you have to change something in driver/dts to make use of it. I hope you can set it back to original mode for further use.

R3 only supports sgmii mode…maybe Hisgmii is for sfp+ (similar to usxgmii)? Maybe you need mode 5 for 2g5 mode,but i guess 3 is right when it worked before.

Thank you for the response. I asked some people here with same router and sfp. Sfp works for them regardless lan_sds_mode setting.

I will try today connect to it via uart and revert setting back. It will be a little tricky. Sfp module hasn’t “spikes” for uart, just tiny spots on the board. I have great soldering skills (0), so I will try to fix cables via paper clips or scotch tape:) Also I need to figure out how to power module.

P.s. Also OpenWRT with default settings can’t connect to the sfp module at 2,5 Gb speed, just 1 Gb. Renaming sfp.ko module and rebooting the router “fix” problem and router can operate at 2,5 Gb. As for my problem - I can’t see sfp module in any case.