Petition to refine information on BPI-W2 hardware support with OS systems in the European Union

Petition to refine hardware support information

  • We have been collecting information for users who have purchased the BPI-W2 motherboard that the manufacturer sells as a possible media center because of the ability to install the Android operating system.

  • The problem is that there is a version of these motherboards on the EU market that are not supported by Android and their installation is not possible. Accumulating users who try to install this operating system on the system board will get a “kernel panic” back, crash, or other BOOT blocking errors. Most in the model that starts with the number “19” returns:

end Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

  • Only the GMS version can be installed on the SD card, but the system will say “crash” or the peripherals will not run as an Ethernet port, so it is unusable for any use of multimedia.

  • Last week we tried 10 BPi-W2 boards and the model on which this operating system was installed is version V1.0 or V1.2 under “18 **”. (so most motherboards do not show this anomaly) All 8 motherboards tested, starting with “19–”, were unable to run the Android operating system.

  • In the moment, we have nearly fifty people back, who meet this anomaly in the for the motherboard with the designation “19xx”.

  • SinoVoip that we have contacted several times does not comment on this.

  • To make this petition possible, we need a certain number of people to suppress Sinovoip to refine this essential information in public sales in the European Union, as it is misleading information - Article to the commercial law L211 & 621

If you purchased a BPi-W2 model in the EU on which you cannot install the Android operating system listed as compatible in the manufacturer’s description, please leave the first two numbers of your W2 base board (see illustration).

Model on which Android works V1.0V1.218”::


Model on which Android returns Kernel Panic V1.2 "19"** and → above :

: KO

The purpose is not to damage the manufacturer’s name and for the time being it is not justified information, but only where the error originated and whether it can be corrected.

(I repeat, for the time being, it is not a subordinate information and the return of people with this problem is a minority)

Thank you for your understanding and we wish you a nice rest of the day.

I bought a Banana to install Linux, but because of the locked kernel it became very limite and ended up in the cupboard :slight_smile:

If I remember correctly, the Android installation also dind’t work on eMMC. Oh, and my number on the montherboard also start witj [19] but the rest I cant’t read.

dear sir:

hardware flag just PCB Manufacturer’s flag. harware is all same . please let me know what issue you have . or you can update your issue log on here??

Hi everyone.

Same problem, same board 1931. Any solution or patch? Android 6 worked well on my previous blue V1.0 motherboards. On the new green 1931, I have a panic of the kernel after installation, but I gave it up a long time ago. :yum:

Sorry, I didn’t have access to a PC, so I only logged in via my mobile device. Android using BPI-COPY :

C3hswitch frequency to 0x00000046
frequency divider is 0x00000080
switch frequency to 0x00000046
frequency divider is 0x00000004
switch to SDR 8 bit
switch bus width to 0x00000008 bits success

hwsetting size: 00000BC0
Goto FSBL: 0x10100000
switch frequency to 0x00000046
frequency divider is 0x00000080
switch frequency to 0x00000046
frequency divider is 0x00000004
emmc_cid[3] = 0xF386A9BC emmc_cid[2] = 0x94D60652 emmc_cid[1] = 0x34465447 emmc_                      cid[0] = 0x38000115
switch bus width to 0x00000008 bits success
DEVICE_TYPE = 00000057
emmc_sec_count = 00E90000
switch speed to 0x00000002 success
switch frequency to 0x000000A6
frequency divider is 0x00000000
1st TX_window = 0xFFFFFFFE
1st phase TX VP0= 0x00000010
RX_window = 0xFFFFF03F
phase RX VP1= 0x00000018
Welcome to FSBL ...
[FSBL] Warm Boot: 0x00000000
[FSBL] Secure: 0x0000BEEE
[FSBL] Flash Type: 0x00000002
[FSBL] DCache Enable: 0x00000000
tee_ltc_alloc_mpa init ...
malloc_add_pool init ...
********** FW_TYPE_GOLD_TEE **********
    FW Image to 0x10200000, size=0x0007A9E0 (0x1027A9E0)
    FW Image fr 0x000C3600
********** FW_TYPE_GOLD_BL31 **********
    FW Image to 0x10120000, size=0x000062A0 (0x101262A0)
    FW Image fr 0x0013E000
********** FW_TYPE_BOOTCODE **********
    FW Image to 0x00020000, size=0x00088BA0 (0x000A8BA0)
    FW Image fr 0x00020E00
md copy audio bin
VERBOSE: bl31_setup
NOTICE:  BL31: v1.2(debug):a6c9ab6
NOTICE:  BL31: Built : 15:16:22, Apr 27 2017
INFO:    BL31: Initializing runtime services
INFO:    Start to init service std_svc
INFO:    Finish to init service std_svc
INFO:    Start to init service opteed_fast
INFO:    Finish to init service opteed_fast
INFO:    BL31: Initializing BL32
INFO:    TEE-CORE: TA RAM slim vesion.
INFO:    TEE-CORE: tee os version : 0
INFO:    TEE-CORE: OTP tee os version : 0
INFO:    TEE-CORE: chip_rev_id : 30000
INFO:    TEE-CORE: check golden fw : 0
INFO:    TEE-CORE: Loaded normal F/W
INFO:    TEE-CORE: tee os version check pass.
INFO:    TEE-CORE: Initializing (b2aa60f-dev #1 Mon Aug 28 13:42:14 CST 2017 aar                      ch64)
MESSAGE: [0x0] TEE-CORE:tee_otp_get_hw_unique_key:49: ************************                           tee_otp_get_hw_unique_key chip id: 30000
MESSAGE: [0x0] TEE-CORE:tee_otp_get_hw_unique_key:54: ************************                           tee_otp_get_hw_unique_key used Kf
INFO:    TEE-CORE: teecore inits done
INFO:    Core_0 got optee_vectors (0x1020093c)
INFO:    BL31: Initialized BL32
INFO:    bl31_to_kernel: kernel_resume_entry = 0x1e000
INFO:    bl31 jumps to EL2: LK entry
welcome to lk/MP
boot args 0x2 0x0 0x0 0x0
INIT: cpu 0, calling hook 0x603e8 (version) at level 0x3ffff, flags 0x1
        arch:     ARM64
        platform: RTD1295
        target:   RTD1295
        project:  RTD1295
        buildid:  81C95C5_MON_SEP__4_01:41:29_CST_2017
initializing heap
calling constructors
initializing mp
initializing threads
initializing timers
initializing ports
creating bootstrap completion thread
top of bootstrap2()
INIT: cpu 0, calling hook 0x5ee30 (sysparam) at level 0x70000, flags 0x1
INIT: cpu 0, calling hook 0x743e4 (lwip) at level 0x70000, flags 0x1
creating bootstrap completion thread for cpu 1
creating bootstrap completion thread for cpu 2
creating bootstrap completion thread for cpu 3
initializing platform
rtd129x_pwm_pin_mux default value 0
PLL_EMMC1 = 0x00000003
switch frequency to 0x46, divder to 0x80
switch frequency to 0x46, divder to 0x4
switch_bus: width = 0x00000002
switch speed to 0x2 success
switch frequency to 0xa6, divder to 0x0
PLL_EMMC1 = 0x00001883
switch erase_group_def to 0x1 success
sec_count = 0xe90000
Erase Unit Size = 512KB * 0x1
factory_init, factory size:0x400000
Factory: pp:1, seq#:0x26, size:0x2c00
sysparam_scan_factory: read SYSPARAM from factory fail!!
Bring UP slave CPUs
tpVEVnREEiRRBBtOBiOOaSSlEESiE: :z :i bnblbgll333 11_1ts__aesetsrtetugpuue

INNNONTOIITOTCTII:CCE E: Ec::p  uB  0  BL,L3B 3L11c::3 a vlv11l1:i .nv2.(g12. 2d                      6ce(oddeebobugbk)uu :gg)0:axa6)46:cac099aa6ccb9b6d

    INCC6EO:8 E) :T BIC a ELtB: 3 1Ll3 e1B:v: Be luL3B 0uil1x:i9lt0 t0 0 :B0u:,i                      1A6r 5lf:t5l1:1 a:6g6:s:2  12,20 25,xA:p1
EA0  p:r27r8 212 6,2802:7   A1R27p
7E rL1 7T2I
IBLnI3ni1t N  @ F0x  O 9B8B0:L 1L 33116:0  0: 0
          i:i atilInailziiitinziagnl giru zinrntuingmt eiru mnest erismveei crvs                      viescr
:  IOsN
  F IO N:  F SO: t  ar Stt  a rStott  aitrtno i itt nosi eitrn vsitie crvseie rs                      vd_c idcs_ets dvcs_st
NFc sI v
F  OI :N
  OI  :N  FOF :i  n  Fis in h iFistnho i tisonh  ittino si iten rvisiterc vesei                       vdc_vt di_csstevd _csst
vNF  Is
F  cOI :N
  O I: NF  O St:  a  Sr tt a Strtota  triotni  ttin o sitie nrsiviertcv ei soece                      rpt voiepcetede _ofepdat_setfe asd
t_Ifa NFs
OtI :N
F OI:N  F  FO i:n  Fi  is nhFi istonh i tsinho i itton  isiten rvisitecr evs eir                      covepti coepeedt e_opeftdase_tefad s_
N   O I:
 F  IO N: F  BO L: 3 B 1L :3  1IBL:n3 i1It:ni ialItinizaiiltniizgaili nzBg iLBn3                       3B2
O    FIN
 :F OIN :  FO  B :L  3B 1L  :31 B:IL n31Ii:tnii aIntliiitzaielaidlz BeiLdz3 ed2B                      L3B
 NO:IFON :F   O  : b  l b31 l_ 3tb1_olt_31oke__rktoen_relknee: lrn:kee rlkn:eer                       lnk_eerlrne_ersleu_msreueRmee_eas_unletmrteenyk_ etG rBny= tEr=y  F  a0=xm 01i0l                      oxy1e 1eeCo00n000t0000

mplNIlFNFeIrONF O3:: O 2     m: bc lbfgl3 3 11=     0j0 u2jub4m
   3pss1   tjtouom  EpELLs 22::to  LL EKKL  e2en:nt trLryyK   e
netif en ip netmask gw
calling apps_init()
------------tmp/factory/video_rpc.bin found
Sink changed, skip one step
tv_system=25 mode=1
Set ACPU share memory
------------tmp/factory/000BootParam.h found
[logo]src w/h=1920/1080 dst w/h=3840/2160
Default Power-Config
*** Reboot-Action : 0xaabbccff ***
PMIC is gmt,g2227
starting app rtkboot
---------------LOAD  NORMAL FW  TABLE ---------------
fw_desc_table_start = 0x00620000
fw_desc_table_ddr_base = 0x0x12418f70
[INFO] fw desc table base: 0x00620000, count: 10
[DEBUG] fw_entry = 0x12419170
Normal boot fw flow...
         FW Image to 0x03000000, size=0x00f22400 (0x03f22400)
         FW Image fr 0x02c17a00
INIT: cpu 3, calling hook 0x22840 (slave_cpu_spin) at level 0x3ffff, flags 0x2
INIT: cpu 2, calling hook 0x22840 (slave_cpu_spin) at level 0x3ffff, flags 0x2
INIT: cpu 1, calling hook 0x22840 (slave_cpu_spin) at level 0x3ffff, flags 0x2
starting app eeprom
starting app pmic
cmd_pmic_entry: set DC force PWM
pmic_testing returns 00
         FW Image to 0x02100000, size=0x000102d8 (0x021102d8)
         FW Image fr 0x028b0200
         FW Image to 0x01b00000, size=0x00327708 (0x01e27708)
         FW Image fr 0x028f0200
         FW Image to 0x1e800000, size=0x007e9000 (0x1efe9000)
         FW Image fr 0x199002000
Booting ACPU...
ao[AotUiDnIgO ]KRoesrSnetal.r.t.T
9 [b0xon02di10n0g0]0 102
DT ch[iFp
 =C] lraesmsiofvye Bononddei n/gp nsucmi
    0[xF0D0T0]0 00a0d1d  bPoBo (t-PsAe)c
[email protected]]yB-raindgd r upto h /wcspeuttsi/ncpg
Finish kylin_bring[_FtDeTm]p  huwpdseattte iMngAC
 aBioo_oHtW iEnmaabgel et]a
rg[eAtO ]aaidod_rC:0RTx0O0n2:8
00S0YS0,_ CsLiOCzKe_:0ENx0AB0fLaEe10 [0 00
x9800000c]: 0x13fec561
SYS_CLOCK_ENABLE2 [ 0x98000010]: 0xd851e416
SYS_CLOCK_ENABLE2 [ 0x98000010]: 0xd871e416
SYS_CLOCK_ENABLE2 [ 0x98000010]: 0xd87fe416
SYS_CLOCK_ENABLE2 [ 0x98000010]: 0xd8ffe416
SYS_SOFT_RESET1 [ 0x98000000]: 0xbfda1001
SYS_SOFT_RESET4 [ 0x98000050]: 0x0000801f
[Audio]SetTickRate  0x000000c8
[ACPU]: Set protect 6 fail, protect 6 is already enable : 0x00000040!!
HDMI Raw Enable: AC3, DTS, MPEG2 AAC, DDP,
SPDIF Raw Enable: AC3, DTS, MPEG2 AAC,
Force 2ch Format: DTS, DTSHD, AC3, DDP, MLP, AAC, WMAPRO,
[AO][InitHDMIVideoType]HDMI Frequecny 148, resolution 25

AIO_O_ACANA_GCTL1 [ 0x98006604]: 0x24951504
AIO_I_ACANA_ADC_GCTL2 [ 0x98006610]: 0x880a3a00
AIO_I_ADC_TCON [ 0x980066fc]: 0x221f0000
AIO_I_ADC_TCON [ 0x980066fc]: 0x221fff00

@@@@@@@One Step TV System magic number = 0xc0de0bee, addr = [email protected]@@@@@@

@@@@@@@@@ boot_info->tv_sys.interfaceType 0
HDMIOff = 0
[VO_SetVideoStandard]st 25 p 1 1 0
[VO_SetVideoStandard]dp_standard:1 data0  0x00000004 data1  0x00000000
[VO_SetVideoStandard]HDMIoff 0 is_tve_on 1 user_cvbs_off 0
[    0.000000] Booting Linux on physical CPU 0x0
[    0.000000] Initializing cgroup subsys cpuset
[    0.000000] Initializing cgroup subsys cpu
[    0.000000] Initializing cgroup subsys cpuacct
[    0.000000] Linux version 4.1.17-g9100299-dirty ([email protected])                       (gcc version 4.9.4 (OpenWrt/Linalvds.format 0 port_setting  0x00000381 lvds_wb 0
vo->mixer_call_dsr: 0x00000000
[VO setTVStandard 25 3D 0 0]

(TVE) TVE_DAC_mode 0,cmd->enProg 1!!
~~comp 0, ch2 1, mode_3D 0!!
~~comp 0, ch2 1, mode_3D 0!!
~~TVE standard#
ro GCC 4.9-2015.06 r47591) ) #20 SMP PREEMPT Wed Aug 14 09:11:59 CST 2019
[    0.000000] Detected VIPT I-cache on CPU0
[    0.000000] alternatives: enabling workaround for ARM erratum 845719
[    0.000000] DT: cma-improve=0
[    0.000000] earlycon: Early serial console at MMIO32 0x98007800 (options '')
[    0.000000] bootconsole [uart0] enabled
SetVideoStandard return!

(VO_ConfigHDMI_InfoFrame) L:275, is_hdmi_plugin 1, hdmiMode 1!!Mode 1 dataByte1                        0x00000040  0x000000a8  0x00000000
dataByte4  0x00000000  0x00000000 int0  0x00000001

(HDMI_3D) mode 1, HDMI_gen 1, En_3D 0, Format_3D 0 scramble:0 rrange:0 yrange:0                       RGB_or_YCbCr:2 Pixel_Colocrt:2 Deep_Color:0 Deep_Depth:0 xvycc:0
@@vo->hdr_ctrl.trans:0 HDMI_gen_dynamic_range_master_infoframe
@@set C1C0 to 2(BT709),set EC2EC1EC0 to 0

 go back SET_HDMI!!
boot_info  0xa001f600 magic  0x2452544b en 1
boot_info.w 1920 h 1080
boot_addr  0x1e800000
boot_osd_buffer_end: 0x81dc8d80
w 1920, h 1080, img0  0x1e800000, pitch0 7680
disp.x 0 y 0 w 1920 h 1080
[AO][_AO_hdmi_module_path_disable] path not enable  0x00000000  0x00000001
Audio_Channel_Count 1 :2CH, audio_layout:0
HDMI_Frequency 148 :1080p50,1080p60
Sampling_Frequency 3 :48K
CTS = 148500, N = 6144
[AO][_AO_hdmi_module_path_enable] path not enable  0x00000000  0x00000001
[    0.138429] bl31_set_tee_protect !!!
INFO:    Non-Secure Boot or 1295 IC_REV >= B00 : no action !!
[    0.207028] bl31_set_tee_protect ret = 0
[    0.624185] ****** rtk_lockapi_init 607, chip: id=0x00000000, revision=0x0003                      0000
[    0.632614] ****** rtk_lockapi_init 614, bypass mode
[    2.745019] rtk-usb-power-manager 98000000.rtk_usb_power_manager: rtk_dwc3_u2                      host status is okay
[    2.754917] rtk-usb-power-manager 98000000.rtk_usb_power_manager: ehci status                       is okay
[    2.763725] rtk-usb-power-manager 98000000.rtk_usb_power_manager: ohci status                       is okay
[    2.772538] rtk-usb-power-manager 98000000.rtk_usb_power_manager: rtk_dwc3_u3                      host status is okay
[    2.788654] rtk-usb-power-manager 98000000.rtk_usb_power_manager: create_debu                      g_files
[    3.162497] [RTD129x PCIE Slot2] 9803b000.pcie2: PCIE device has link down in                       slot 2
[    3.171215] [RTD129x PCIE Slot2] 9803b000.pcie2: rtk_pcie2_hw_initial fail
[    3.334321] [RTD129x PCIE Slot1] 9804e000.pcie: PCIE device has link up in sl                      ot 1
[    3.353455] rtk119x-ir 98007000.irda: [rtk119x_ir_probe]: can't get multiple                       support from dtb, set to default->not support

[ROS: openRPC() intr_scpu_dev_r buf  0x00e2ffa1 s  0x00e2ffa1 e  0x00e4ffa1 i  0                      x00e2ffa1
[ROS: openRPC() kern_scpu_dev_r buf  0x00f2ffa1 s  0x00f2ffa1 e  0x00f4ffa1 i  0                      x00f2ffa1
[ROS: openStubRPC() intr_w buf  0x00e6ffa1 s  0x00e6ffa1 e  0x00e8ffa1 i  0x00e6                      ffa1
[ROS: openStubRPC() kern_w buf  0x00f4ffa1 s  0x00f4ffa1 e  0x00f6ffa1 i  0x00f4                      ffa1[AVCPU] Set Debug level flag  0x81dd3fb4 *flag  0x01dbf000 ucache  0xa1dbf00                      0
[AVCPU] Set Debug level *ptrDebugFlag  0x00000001
Audio Version =  0xc23d38fe (Kylin)
Audio Commit Date = Aug 8 16:38:52 2018
Common Version = 96d1895f3ec19f691483a0e3eec64b9684f6e548
Binary src compiled at Aug  8 2018 19:56:05
Note =

[A] gloabl malloc size  0x003ffd48
[    3.461906] AudioIntrRead:154 can't find process for handling AudioIntrRead p                      rogramID:98
[    3.470299] AudioIntrRead: program:98 version:0 procedure:1 taskID:0 sysTID:4                      294967295 sysPID:4294967295 size:4 context:81dd3765 atomic
[    3.637669] [HDMI RX ERR][hdmirx_rtk_drv_probe] Get top_supply fail -19
[    3.644860] cec_core_init, register cec_bus ffffffc00112a4f8
[    3.650716] register cec driver 'cec' (ffffffc00112a678)
[    3.656175] register cec device 'cec0' (ffffffc00112a770) to cec0
[    3.662457] [cec_bus_match name = cec0,len=4,drv_name=cec]
[    3.668087] probe : cec_dev 'cec0' (ffffffc00112a770), cec_drv 'cec' (ffffffc                      00112a678)
[    3.676666] register cec device 'cec1' (ffffffc00112aa20) to cec0
[    3.682948] [cec_bus_match name = cec1,len=4,drv_name=cec]
[    3.688576] probe : cec_dev 'cec1' (ffffffc00112aa20), cec_drv 'cec' (ffffffc                      00112a678)
[    3.739999] reg = 0x330800
  • Android6 = blocked on the line : [ 3.739999] reg = 0x330800
  • Android7 = end Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
  • I will deliver the log with Kernel Panic immediately after installation.

But as I state, on the motherboards BPI-W2 V1.0 and V1.2 starting with the number 1827 I do not show these post-installation problems and against 19 ** Android works on them.

The test was performed on 10 motherboards :

  • 1x V1.0 : OK
  • 2x V1.1 18** : OK
  • 7x V1.1 19** : Kernel Panic or blocked on the line : [ 3.739999] reg = 0x330800 -Or

—[ end Kernel panic - not syncing: Attempted to kill init! exitcode=0x0000000b

[    2.352881] [<ffffffc00028567c>] el1_irq+0x7c/0xf0
[    2.358266] [<ffffffc0002e3268>] cpu_startup_entry+0x3a0/0x410
[    2.364823] [<ffffffc000290214>] secondary_start_kernel+0x164/0x1b8
[    2.371868] CPU0: stopping
[    2.374907] CPU: 0 PID: 0 Comm: swapper/0 Tainted: G      D         4.1.35-04005-dirty #3
[    2.384103] Hardware name: Realtek_RTD1296 (DT)
[    2.389192] Call trace:
[    2.391937] [<ffffffc00028a7ac>] dump_backtrace+0x0/0x164
[    2.398005] [<ffffffc00028a934>] show_stack+0x24/0x30
[    2.403682] [<ffffffc000bbbd40>] dump_stack+0x88/0xa8
[    2.409359] [<ffffffc000290920>] handle_IPI+0x2c0/0x2cc
[    2.415231] [<ffffffc0002824d0>] gic_handle_irq+0x88/0x8c
[    2.421298] Exception stack(0xffffffc000f73db0 to 0xffffffc000f73ee0)
[    2.428540] 3da0:                                     00f76000 ffffffc0 00000000 00000080
[    2.437738] 3dc0: 00f73f00 ffffffc0 00286d00 ffffffc0 002e3268 ffffffc0 00000000 00000000
[    2.446936] 3de0: 00f79000 ffffffc0 00000001 00000000 0000031e 00000000 00000008 00000000
[    2.456134] 3e00: 7889a98b 00000013 80b583eb 61c88646 00f85bc0 ffffffc0 00f70000 ffffffc0
[    2.465332] 3e20: 00000000 00000000 00000000 00000000 00000000 00000000 ffffffff ffffffff
[    2.474530] 3e40: ffffffff ffffffff c1f3c420 ffffffbd 00000000 00000000 011cec30 ffffffc0
[    2.483729] 3e60: 0000000f 00000000 00f76000 ffffffc0 00bcf000 ffffffc0 00000000 00000000
[    2.492927] 3e80: 00f51b40 ffffffc0 01037000 ffffffc0 00000000 00000000 00f571a0 ffffffc0
[    2.502125] 3ea0: 00f70000 ffffffc0 00d69000 ffffffc0 00000000 00000000 00f73f00 ffffffc0
[    2.511323] 3ec0: 00286cfc ffffffc0 00f73f00 ffffffc0 00286d00 ffffffc0 60000045 00000000
[    2.520521] [<ffffffc00028567c>] el1_irq+0x7c/0xf0
[    2.525905] [<ffffffc0002e3268>] cpu_startup_entry+0x3a0/0x410
[    2.532462] [<ffffffc000bb89a8>] rest_init+0x8c/0x98
[    2.538042] [<ffffffc000ea496c>] start_kernel+0x390/0x3a4
[    2.544109] CPU3: stopping
[    2.547147] CPU: 3 PID: 0 Comm: swapper/3 Tainted: G      D         4.1.35-04005-dirty #3
[    2.556342] Hardware name: Realtek_RTD1296 (DT)
[    2.561431] Call trace:
[    2.564176] [<ffffffc00028a7ac>] dump_backtrace+0x0/0x164
[    2.570245] [<ffffffc00028a934>] show_stack+0x24/0x30
[    2.575922] [<ffffffc000bbbd40>] dump_stack+0x88/0xa8
[    2.581599] [<ffffffc000290920>] handle_IPI+0x2c0/0x2cc
[    2.587471] [<ffffffc0002824d0>] gic_handle_irq+0x88/0x8c
[    2.593539] Exception stack(0xffffffc02220bdf0 to 0xffffffc02220bf20)
[    2.600780] bde0:                                     00f76000 ffffffc0 00000000 00000080
[    2.609979] be00: 2220bf40 ffffffc0 00286d00 ffffffc0 002e3268 ffffffc0 00000000 00000000
[    2.619177] be20: 00f79000 ffffffc0 00000001 00000000 00000506 00000000 00000008 00000000
[    2.628375] be40: 583afe8f 00000008 83453113 00000000 221ff2c0 ffffffc0 22208000 ffffffc0
[    2.637574] be60: fefeff3f fefefefe 7f7f7f7f 7f7f7f7f 01010101 01010101 00000018 00000000
[    2.646772] be80: fffffffe 0fffffff 0000000e 00000000 00000007 00000000 00c2c000 ffffffc0
[    2.655970] bea0: 00000002 00000000 00f76000 ffffffc0 00bcf000 ffffffc0 00000000 00000000
[    2.665168] bec0: 00f51b40 ffffffc0 01037000 ffffffc0 00000000 00000000 00f571a0 ffffffc0
[    2.674366] bee0: 22208000 ffffffc0 00d69000 ffffffc0 00000002 00000000 2220bf40 ffffffc0
[    2.683565] bf00: 00286cfc ffffffc0 2220bf40 ffffffc0 00286d00 ffffffc0 60000045 00000000
[    2.692762] [<ffffffc00028567c>] el1_irq+0x7c/0xf0
[    2.698146] [<ffffffc0002e3268>] cpu_startup_entry+0x3a0/0x410
[    2.704704] [<ffffffc000290214>] secondary_start_kernel+0x164/0x1b8
[    2.711751] ---[ end Kernel panic - not syncing: Attempted to kill init! exitcode=0x0000000b
[    2.711751]

PS: I’m sure you have one BPI-W2 (V1.1 - 19 **) on hand, see for yourself :slight_smile:

Hello My bpi: 1931 | CM64 94V-0 What must be done to reach you? I paid for this card 96 euros and I can’t do anything with it. If you have to file a complaint or make a complaint, I would do it, please give me the steps to follow. I’ve been breaking my head over it for 1 month and nothing is working. I have the proof of payment from Aliexpress. Thanks for your help. Cordially.

Pensez au bpi w2 Merci

Good day. According to the commercial law / article on the claim for defective goods, request a refund. warranty. Log in to your Aliexpres account → your orders → return the product as defective / refundable.

Motherboards marked 1931 show various anomalies. Either damaged EMMC, damaged printed circuit board etc. (Probably some bad boil that was not checked for quality and PHY control)

Just out of curiosity, your problem is exactly what? In installation or in use? (In case of EMMC damage, you still have the option to use PORT SD.)

Hello Thank you for your answer, it’s been 2 months since I tried to install an OS that works on my BPI, obviously these are only images provided by the forum, when the installation is successful I still have something not working , the card goes out by itself and it heats up a lot. I also tried to compile the kernel with BSP I managed to make it work but it does not stay functional for long. If I had known that about this famous BPI I would never have bought it. The .img offered by Sivinoip do not even work half the capacity of the card. Why sell this card if we can’t do anything with it! Kernel, driver, os, etc … Thank you. Cordially.

Here I went on the Aliexpress site on my order and I requested the return of the product against reimbursement. Thanks again. I will take another cart but especially not a Bananapi I was very disappointed. With the same characteristics as would you advise me? Sorry for this little hs.

I also have problems with temperatures. Even with a CPU passive cooler, I had temperatures around 60-80C ° at half load. When booting BPI-W2, you can see a lot of bugs, whether it’s Ubuntu or debian.

• Personally, I am very satisfied with the ODROID products. I use Odroid N2 + for Android TV OS : (In addition, they have a very active community.)

• I used for a home server some time ago : ODROID-HC2 : Home Cloud Two. But today it is not somehow advantageous, or the file is intended only for the less demanding

• I’m just going to buy my PC called CPu x86 Odroid H2 + base with 2x 2.5Gb ports (functional against Banana) for NAS + Plex Server base - The CPU J4115 supports HW encoding with plex

PS : I totally understand you. BPI-W2 is very depressing, moreover, when only half of the thing works. The saddest thing is the fact that Sinovoip is completely indifferent to customers in terms of technical support. It seems to me that he will build some SoC, but the customer has to build his own OS on it himself and search the Internet for how to make at least part of the motherboard … No less, Banana knows these practices worldwide. (Technical support is maintained here only by a couple of volunteers.)

Installation of the MALI graphics driver with official SinoVoip images is also not possible.

But you are not alone. Everyone who bought the BPI-W2 because of 2x LANs, DisplayPort etc regrets it, as it is basically not possible to use them effectively. The same PCie that supports perhaps only one almost 7-year-old Wifi card. :slight_smile:

Good luck.

Hello Selling is the only goal of Sinivoip, on linux for more than 10 years I have never seen that, to “crash” Linux really has to be done! Anyway, I thought about Odroid I’ll see that, one thing is sure Banapi finished for me, again a big thank you for your help and support. The Bananapi left today, what a relief.

Hello Thanks again for your suggestion, this is the top Odroid. Even though I lost about 30 euros to the return of the bpi-w2 I don’t regret it.

1 Like

Cool. Un jolie ensemble. T’aurais pu passer la commande chez, mais vis-à-vis le prix, ca vient en même (je crois). Combien as-tu payé pour les frais douane ? Sinon une belle boite, un vrai changement par rapport à BPI- * ? :smiley:

PS: De plus, CPU x86 permet d’installer pratiquement n’importe quel système d’exploitation. 2x 2.5Gb LAN ca envoi forte.


I paid 46.50 euros for customs, I don’t really regret it is a very very good card. Thanks for your advice.