Odroid ubuntu IMG for BPI-M5

1.download odroid IMG:https://dn.odroid.com/S905X3/ODROID-C4/Ubuntu/

2.Burn IMG: sudo dd if=xxx.img of=/dev/sdx

3.download uboot: https://drive.google.com/file/d/1bXz9gUnrXE0SjafvGevDFpbXwxFZ2Q6T/view?usp=sharing

4.Burn uboot:sudo dd if=./u-boot.bin of=/dev/sdx conv=fsync,notrunc bs=512 seek=1

Hi Tony, can you give me access to download the uboot? Thanks!

Hi Jorge,Use this link:https://drive.google.com/file/d/1bXz9gUnrXE0SjafvGevDFpbXwxFZ2Q6T/view?usp=sharing

If you have any questions, you can communicate. I am also an open source hardware enthusiast.

Thanks Tony, I have two que questions more:

  1. ¿Do you modify boot.ini after flash odroid c4 img?
  2. ¿Do you replace dtb files from BPI-M5 linux image or keep the same for odroid c4 img?

I thank you in advance

Great to know that! I’m not very skilled on SBC but I want to learn how to mod Odroid C4 third-party images and porting to BPI-M5. I’m very interested on porting LineageOS for Odroid C4 to BPI-M5. Do you have any ideas how to doit?

  1. I did not modify boot.ini.
  2. I am porting M5 uboot on odroid open source.
  3. If you want to modify dtb, you can compare M5 dtb to odroid open source compilation.

The hardware of odroid c4 and bpi-m5 is almost the same. The main difference between them is the difference between ddr and several gpio.

I will try it, I don’t know what the result will be.

Hi Tony, I tried the u-boot.ini and boot the odroid ubuntu image but the USB ports won’t work. I solved that replacing dtb file by the BPI distro dtb file and the files in amlogic folder. After that the USB ports are working. I tried too LineageOS for Odroid C4 but doesn’t boot. Thank you for your help.

Is there any way to run armbian for BPI-M5 , there is armbian image for ordroid , how to modify for BPI-M5

With a sd card with ubuntu for RPI-M5 flashed, replace the BPI-ROOT partition by rootfs partition from Armbian for ODROID C4 image.

Hi, jhortwo. Recently I was making bpi-m5 armbian firmware, but it has not been successful. Can you give a specific method? Thank you!

Hi Tony, this is the way I make it work:

1 Like

Can this boot over Android in emmc ? While this uboot is flashed on. Sdcard ?

Hi,jhortwo。I verify ok. thank you very much!

emmc is empty,flash uboot to sdcard。

Hi,spikerguy. Is the situation you are talking about a dual system?

I tried all the methods used to boot over bsp uboot but nothing seems to work.

Is there a maskrom button and which one is it as I see 4 switches on the board.