Novice BPI-W2 nothing works as it should, SATA, Power, very slow

I bought a Banana BPI-W2 for a multimedia station, but unfortunately nothing works.

1. The first problem is not to use SATA How do I connect SATA ports? I’ve tried different distributions, but neither can start or use SATA ports, they’re not visible.

2. The system is terribly slow When using Ubuntu Serever 16.04, or other Linux distributions, everything is terribly slow when I write a word, so it appears in “2-3 seconds”, the CPU is still busy at 80-100% (full charge) outside OpenSuise, where the CPU is at 10%… (Ubuntu Server, Ubuntu Mate)

3. Power button The Power button does not work for me either, apparently it has no function? So I have to start the device either via the RESET button or by disconnecting it from the mains and plugging it in again (don’t be angry with me, but this is not normal and acceptable). Is there any “normal way” how to run the device without having to pull it out of the electricity?

4. Documentation Is there any documentation and instructions (User manual) on how to proceed with installation and configuration? (outside of one site at where there is just a few links and links, nothing more. Or is it just “do it yourself”?

Is my board defective or is it a feature of this device? I can still return it within 14 days, so I would either try to solve my problems, or I will have to try another manufacturer (unfortunately). I chose BPI-W2 mainly because of SATA ports, but if it is not possible to use it, then this device is worthless to me…

Thank you for any help.


sata works for me on official ubuntu image found on this forum - kernel 4.9 if i remember correctly i had to re-compile kernel for btrfs / RAID to operate but otherwise /dev/sataa and /dev/satab were discovered right away.

check your power source - maybe you have not enough juice to power those drives ? i had 2.4A 12V supply and by W2 kept on rebooting when trying to spin-up 2.5inch hdds during bootup. attached usb-c smartphone charger to usb-c to provice additional power - it worked like that

bought 12v 4A (or sth - do not remember now and I am not at home) - this time everything worked fine with single power source

Do you have a link (url) to this Ubuntu? Or at least a reference to the kernel compilation? (how re-compile kernel for btrfs).

  • Unfortunately, the “download” section of this page doesn’t work :slight_smile:

Not Found The requested URL /download.html was not found on this server.

  • Under Ubuntu those disks (disk) dev / satta I see, but is like “unknown” is not possible, or do not know how to “mount” them.

*I tried more disk, re-fromat etc, no change. PS : Otherwise I use 12V 3A power supply (~35W).

In any case, thank you very much “Kamil” for your answer !!! sataa

UPdate 27/11/2019 : 23:10
With Ubuntu ver 09/16 mount HDD from SATA -> mount /dev/sata1 work !!

1 to build as in guide. Another option in menu after running is configure (4 or 5 if I remember right) - go through modules and mark them as built-in or module to load/unload as needed, save config and go with opt 1 to build it

It worked for me without need for docker but I guess I have used older version of source code.

1 Like


Thank you so much Kamil !! Indeed, with KERNEL recompilation I can mount the HDD without problem. Thank you for your help. It’s sipmitic :slightly_smiling_face: . Michal.