No system loaded on BPI-M5 :-(

Hi, I received my BPI-M5 and I was initially intended to flash eMMC with ubuntu 20.04 server, starting from SD. Actually, it is extremely unstable (few command after booting it enters in an error loop). With ubuntu 20.04 desktop apparently it boots but no way to click on firefox or setting or any of the clickable options. Worse with Android or CoreELEC (not even start). I would blame my SD (256 GB), but I tried to flash also a different SD of 2 GB for Android and CoreELEC but still no success. Any suggestion? I did not do anything related to eMMC: as I saw that I could boot from SD I think I am doing the correct thing

1 Like

may be your sdcard is incompatible, my 256G and 16G sandisk A1 cards works well. it’s recommended to use A1 rated cards. 8GB at least.

Android only support boot from emmc.

https://wiki.banana-pi.org/Getting_Started_with_M5/M2Pro

Yes, I guess sdcard is the problem: waiting for a new one, 32 GB sandisk A1 (should work!). Thank you, I didn’t know that Android boots only from eMMC, actually I am not interested in Android, it was just an attempt to see if something was working. Do you know if 4K screen if REALLY manageable? I guess and expect so!

OK, my SD card was not adequate: with a proper one (A1 instead of A3) I could manage a stable system. Anyway, I could not flash eMMC with ubuntu system. After booting, I gave this two commands:

$ sudo mount /dev/sda1 /mnt
$ sudo apt-get install pv unzip

$ sudo unzip -p /dev/sda1/2023-03-01-ubuntu-20.04-server-bpi-m5-m2pro-aarch64-sd-emmc.img.zip | pv | dd of=/dev/mmcblk0 bs=10M status=noxfer

Unfortunately, the following message appeared: “failed to open ‘/dev/mmcblk0’: Permission denied” My knowledge of UNIX is almost zero, so waiting for kind suggestions

changing the last command into

$ sudo unzip -p /dev/sda1/2023-03-01-ubuntu-20.04-server-bpi-m5-m2pro-aarch64-sd-emmc.img.zip | pv | sudo dd of=/dev/mmcblk0 bs=10M status=noxfer (adding another sudo before dd)

the system answer is

0.00 B 0:00:00 [0.00 B/s] [<=> 0+0 records in 0+0 records out

which seems not to have done anything :frowning:

try https://www.armbian.com/bananapi-m5/

Problem finally solved: these were the commands that worked for me:

sudo apt-get install pv

sudo mkdir /media/usb

cd /media/usb

UBUNTU SERVER UP AND RUNNING

sudo mount /dev/sda1 /media/usb

sudo bpi-copy 2023-03-01-ubuntu-20.04-server-bpi-m5-m2pro-aarch64-sd-emmc.img.zip /dev/mmcblk0

Screenshot%20from%202023-03-20%2010-22-08

you are referring to a previous message and yes, first command was incorrect. My system is up and running now. I flashed eMMC using bpi-copy command. As per 2023-03-01 image, it seems to work fine.

I think I will give to armbian a try. I tested it on another SBC and it worked well. Anyway, I got ubuntu working fine on the M5